Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • trevorj
    replied
    Update: I got the database running by copying the my.ini file to my install directory in the DBProvider\Bin folder then adding the MySql service
    Code:
    C:\Program Files (x86)\ShoreTel\ShoreTel CCIR Server\DBProvider\Bin>mysqld --install MYSQLUpg --defualts-file="C:\Program Files (x86)\MySQL\MySQL Server 5.7\my.ini"
    Now I am failing to connect to the old database. Log below:
    Code:
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    
    
                   Restart of the system
    
    
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    
    ECC version 507.84.5100.0 SUPERVISOR: Set redundancy mode to UNKNOWN
    SUPERVISOR(Wed Jul 24 14:06:23 2019): Starting Subsystem: EOS_TH1
    readTableFromFile initialized = TRUE
    SUPERVISOR(Wed Jul 24 14:06:23 2019): Started Subsystem : EOS_TH1 
    SUPERVISOR(Wed Jul 24 14:06:23 2019): Starting Subsystem: LDS_TH1
    SUPERVISOR(Wed Jul 24 14:06:23 2019): Started Subsystem : LDS_TH1 
    SUPERVISOR(Wed Jul 24 14:06:23 2019): Starting Subsystem: UPG_T1
    
    DBUpgrade:CheckIfServiceExists: Checking if MySQLUpg exists.
    DBUpgrade:CheckIfServiceExists: The service is starting.
    redundancy mode = 0, reporting server = false
    
    DbUpgrade: ConfUpgProcess: Failed to connect old database (upg_ecc). 
    Will try again.
    .....
    DbUpgrade: ConfUpgProcess: Failed to connect old database (upg_ecc).
    
     ========================================================                           
     = The migration of the configuration data did not                               
     = complete, therefore the system will not be started.                           
     ========================================================                          
    
    
    Stopping ShoreTel Contact Center
    SUPERVISOR(Wed Jul 24 14:06:44 2019): Started Subsystem : UPG_T1 
    SUPERVISOR(Wed Jul 24 14:06:44 2019): Going to stop the system...
    
    SUPERVISOR(Wed Jul 24 14:06:44 2019): Stopping Subsystem: EOS_TH1
    SUPERVISOR(Wed Jul 24 14:06:44 2019): Killed Subsystem  : EOS_TH1 
    
    SUPERVISOR: Exiting!

    Leave a comment:


  • trevorj
    started a topic CCIR Install Error

    CCIR Install Error

    Hello all,

    We are running into an issue installing CCIR.

    We have installed MySQL on the server along with CCIR server. The CCIR has been setup in CCD and reports the station. However it doesn't seem to be storing the data in the MySQL database.

    The ECC Tail log indicates an error connecting the the database, the log file is below:

    Code:
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    
    
                   Restart of the system
    
    
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
    
    ECC version 507.84.5100.0 SUPERVISOR: Set redundancy mode to UNKNOWN
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Starting Subsystem: EOS_TH1
    readTableFromFile initialized = TRUE
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Started Subsystem : EOS_TH1 
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Starting Subsystem: LDS_TH1
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Started Subsystem : LDS_TH1 
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Starting Subsystem: UPG_T1
    
    DBUpgrade:CheckIfServiceExists: Checking if MySQLUpg exists.
    DBUpgrade:CheckIfServiceExists: Could not open the service.
    redundancy mode = 0, reporting server = false
    
    DbUpgrade: Error while connecting to database.
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Started Subsystem : UPG_T1 
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Starting Subsystem: NET_TH1
    NET: Adapter - 0 
    NET: Addr = 192.168.7.65, stn = 1
    NET-STATIONS-Stn1 2 
    NET-SSL: Cannot load CA file 
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Started Subsystem : NET_TH1 
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Starting Subsystem: C2GS_T1
    SUPERVISOR(Wed Jul 24 13:10:16 2019): Started Subsystem : C2GS_T1 
    SUPERVISOR(Wed Jul 24 13:10:16 2019): System has been started !
    Any advice would be appreciated, I'm not sure if there was a step missed during install; It seemed pretty straightforward at first glance.
Working...
X