Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ECC - Enhanced Reports - Will Not Email

    I have scoured the internet and also have read all the documentation that I have access to regarding being able send the Enhanced ECC reports via email on a Historical Schedule. I have Ghostscript installed, and the printer assigned with the correct naming, etc. I have set up the report to be on a schedule, but no matter what I do the report will not send. The SMTP settings are configured properly and should not be causing any issues.

    There are no logs showing in the ECC report as to whether it was being sent or to show any forms of errors, etc.

    Has anyone else run into an issue like this, and does anyone have any troubleshooting tips or instructions that may be helpful to resolve this issue?

  • #2
    see if this helps out at all https://www.shoretelforums.com/forum...-to-pdf-on-ecc

    Comment


    • #3
      Thanks, allano. Will look deeper into this.

      Comment


      • #4
        Does the report run. This can be viewed from the Report application by going to the scheduler and viewing the logs. Modify the report to just save to a local folder, without emailing to ensure the report is generated. Once verified, add the email information back into the scheduled report.

        Check the email configuration in ECC. Check the local server SMTP folders to see if the emails are being rejected and the reason why. If the ShoreTel Director is configured to attach voicemails as an email attachment and it is fully operational, you can change the ECC server's SMTP settings to forward all emails to the ST Director server for delivery.

        Comment


        • #5
          I'm having a similar issue but it's specific to GhostScript/PDF generation. I have a scheduled report and if it's setup to generate a .csv or .xls file it'll run fine and email me the report. But if it's setup to generate a PDF, it fails. The logs show the report gets generated but it fails a few steps later when it tries to export the report. A PDF file is generated on the ECC server but it's 0 bytes and I can't open it. The email never gets sent because the file wasn't successfully generated.

          I've also installed GhostScript locally on my machine and I generated a report and tried to export. Again, if I export to .xls or .csv it's fine but when I try to export to .pdf I get an error saying "Cannot export the report to the 'C:\Users\XXX\Desktop\XXX.PDF' file". I tried following the thread allano referenced above and my GhostScript printer is configured the same on both my machine and the ECC server. I have some questions about the printer account portion though. My understanding is that the printer account that's specified in ECC Director > Maintenance > Printer Account is used only for the scheduled jobs. The reason for this is because you need to specify an account that has permission to the GhostScript printer on the ECC server.

          Well what's odd is that if I specify my admin account, the test on the ECC page succeeds and then I am able to modify my scheduled job and choose PDF (even though it doesn't actually work when the job runs). My admin account is not a user on ECC. If I change the printer account to my normal, non admin account, which isn't in ECC either, the test still succeeds but then I get an error when I try to choose PDF in my scheduled job. And finally, if I enter a local user that is in ECC but is not a domain user then the test fails. So I am super confused on what exactly the requirements are for this printer account. The GhostScript printer's permissions are setup to allow "Everyone" print access so that's why I'm guessing the tests succeed when I specify a domain account (whether it's my normal account or admin account) because those can actually authenticate whereas the local user cannot. But I don't get why I can't choose PDF when it's configured with my normal account. I also tried to use a service account that has admin rights to the ECC server and that one behaved the same as my normal account. I don't know what's special about my admin account.

          But the printer account should be irrelevant for my manual export attempt and that still has issues. Any suggestions would be appreciated!

          Comment


          • #6
            I was able to resolve my issue. I uninstall GhostScript 9.22 and installed 8.71. I also disabled driver signing enforcement before installing 8.71. And regarding the issue with the Printer Account, I came to find that it's picky and wants you to input the user that installed GhostScript (even if another account has admin rights to the ECC server). So when I installed GhostScript 8.71, I did it with a service account that has admin rights instead of my personal account. This way I don't have to update the printer account uesr/password every time my account's password changes.

            Comment

            Working...
            X