Welcome to

Welcome to!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel/Mitel systems. ShoreTel/Mitel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel/Mitel, Inc. although you may find ShoreTel/Mitel employees sharing there experiences and expertise. If you would like more information on ShoreTel/Mitel systems, contact BTX at [email protected]

As always please support the advertisers that help support our site.

Thank You,
See more
See less
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues with Queue Monitor and Forced Release Notification

    We have recently installed the ECC application into our environment. We are still having issues getting the queue monitor to populate for all agents. We have given the agents permissions to view the queue monitor (and pick up calls) and have set the queue to broadcast, but still not populating.

    We have also tried to use the pop-up on forced release function to notify agents when they have been released. We have them minimize their toolbars, but the window does not rise when they are put into a forced release.

    Has anyone experienced these issues and have any ideas?

    Any help is appreciated. Thank you.

  • #2

    Are you working in a Citrix environment?
    What version of ECC are you using?

    Have you read this thread? it may help you:


    • #3
      We are not using Citrix. . .most Agents are working through an MS Terminal Server session. We are on version 5.1 of ECC.


      • #4
        That is very very strange.
        There used to be a problem in 5.0 where terminal services/ Citrix showed the symptoms you describe. This was because 5.0 used UDP to send this data to the clients.

        If you are 100% sure you have 5.1 installed (server and agents) then you need to contact ShoreTel support. If you have 5.0 you can use the instructions on the thread I gave you in my previous post.


        • #5
          Thanks for the suggestions. I have been working my third party support whose has escalated to ShoreTel who all still don't what is happening. Thanks for the tought about traffic.