Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CC agent toolbar queue is blank

    We are using Contact Center Agent 4.66.05 and have had random agents complain that their queue window is blank. This has moved around between a few agent PCs, and even came up correctly a day later on a fresh install of Windows XP Pro.

    I have tried removing the software, folder, easyrun in the registry, and Java. Then rolling back to an older version of Java (Although I do see a JRE folder within the install. [j2re-1_4_2_09-windows-i586-p])

    Has anyone experienced this and had a step by step solution that is stable? We have tried reboots, reinstalls, reg. cleaning, and we have not officially documented a fix. Also agents that the queue had stopped working have had it return. Out of about 30 agents 3-4 have issues with the blank queue box, and it also carries old video if moved around the screen. (Almost as if a box refresh issue).

    Thanks

  • #2
    We ran into the same issue with 4.35.11. Our voice and data are different physical subnets connected via the firewall.

    If I remember correctly, it was because the Queue info was broadcast via UDP from the CC server and we had to make a registry change to force the Queue info broadcast via TCP.

    Not sure if this helps or not, but good luck!

    Comment


    • #3
      Anybody know the details of this registry change? We have a similar problem that this may fix.

      Comment


      • #4
        Here's a screen shot of the registry entry for TCP, it's under \\HKEY_LOCAL_MACHINE\SOFTWARE\Easyrun\BSW\Net

        I don't recall if we had to manually enter the registry entry for Usetcp at the bottom or not but hopefully this helps.
        Attached Files

        Comment


        • #5
          In the registry (or registry.ini in 5.0 and up) delete "udp port" and "useudp" under the NET key on the server. Then restart the server and ECC should start using only TCP. Keep a backup though in case you need to revert.

          Comment


          • #6
            We made the registry changes listed here. However, it did not work. After rebooting the contact center server, I tried starting contact center. As it was starting, it showed an error connecting to the database. (I apoligize for not having the exact message), and it rebooted the server. There was a prompt that I didn't see at first that said I could stop the reboot by pressing ctrl-c.

            The application event log shows 2 errors. First, it logs "The following information is part of the event: EpicSup, SUPERVISOR(Sun Sep 20 08:58:04 2009): Subsystem NET_TH1 hasn't been started." and then it logs "The following information is part of the event: EpicSup, SUPERVISOR Failed to Initialize the System Going to Restart."

            Any thoughts?

            Comment


            • #7
              I am sorry but I believe I was mistaken.
              However, here is how you do it.

              First, don't forget to make a backup of your registry or registry.ini

              In the registry or registry.ini you look for a key called NET-UDP-QUEUE1.
              Under this you should see name=ETS_UQ1.

              This is what tells ECC to use UDP for the agent.

              There is also NET-UDP-QUEUE2 which tells ECC to use UDP for the agent wallboard.

              Delete both keys. Then, find the key [NET-UDP-QUEUES].
              You should see Count = 2. Change it to Count = 0

              Restart the server and UDP will no longer be used.

              Please tell me if this worked for you.

              Comment


              • #8
                Gulu - thanks. I was able to start contact center after making these changes. I haven't yet verified if this corrects the problem with the agent toolbar; I will do that when agents are logged in. Thanks for the help.

                Comment

                Working...
                X