Welcome to

Welcome to!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel/Mitel systems. ShoreTel/Mitel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel/Mitel, Inc. although you may find ShoreTel/Mitel employees sharing there experiences and expertise. If you would like more information on ShoreTel/Mitel systems, contact BTX at [email protected]

As always please support the advertisers that help support our site.

Thank You,
See more
See less
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange CC Agent Issue

    We have our Contact Center server installed in Site A here in the US along with the majority of our customer support reps who use Contact Center. Site B is in one of our overseas office and houses 1 agent who does overnight support. Site B had a new firewall put in, all Firewall rules were put back in place to match the replaced firewall. Shoretel phones worked fine, incoming and outgoing calls were made fine. However our Agent would try to launch his agent tool bar to login and it would hang at "trying to connect". It wasn't until the local IT staff forced his machine to pick up a new IP address that the tool bar started working. Any ideas why the IP address change cleared the issue? The replacement firewall was given the same Ip address as the original. My network engineers are asking in case we get any more issues like this with Contact Center agents in other offices.

  • #2
    Here's a stab in the dark.. Name Resolution?

    Was that agent trying to resolve the CC server's IP by name and when it got a new address it got a new Name Server as well?


    • #3
      Which version of CC are you using?


      • #4
        Version 4.35.11


        • #5
          In 4.35.11 there were some issues with the way agents connected to the server. Specifically, the agent's network process tried to bind itself to a specific IP address and adapter. I think you won't have any such issues in 5.0 or even 4.66 (though as long as you are upgrading, upgrade to 5.0 I would think)