Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • When syncing from AD fill in email address from AD(email) not AD(userPrincipalName)

    Currently when syncing a user with Active Directory, the email field is filled in by the AD(userPrinicpalName) field. This doesn't make since. The email addresses in our organization and the userPrincipal name are not the same. If they filled in the email address with the AD(email) field wouldn't that make more since, and guarantee that the email field gets filled in with the correct information?

    At the very least, let us choose which way we want it populated.

  • #2
    I would agree with Nomad on this. For example, our active directory domain is "pathfinder.local" and our e-mail domain is "pathfinderservices.org". Currently this problem with AD integration is preventing us from using that feature. I have a request open with support on it, but so far they haven't admitted that this is a problem.

    Comment


    • #3
      I did find a work around for this. Not sure if it saves anytime, but if you set up the user as and AD user in ShoreTel, sync with AD, then uncheck the Active Directory User checkbox, put in the correct email address, then recheck the box and save, it will save the user with the correct email. Again, I don't know if it is worth it or not.

      When I contacted my ShoreTel dealer and they intern contacted ShoreTel I got this back:

      Confirmed with development that the UserPrincipalName field to populate the e-mail address from AD. This was recommended by Microsoft (so it is not the wrong filed). There are no changes planned to this implementation.

      Regards,

      Andrez Chavez
      My feeling is that just because it was designed a certain way, doesn't mean it's not wrong.

      Comment


      • #4
        Originally posted by Nomad View Post
        My feeling is that just because it was designed a certain way, doesn't mean it's not wrong.
        This seems to be a perpetual problem with ShoreTel. They do not want to "Own Up" to their problems, they always try and throw it back at the customer. I have only been a ShoreTel User since March, maybe it hasn't always been this way. But ShoreTel needs to change their attitude quickly or they are going to drive away customers. I have a hard time purchasing more equipment to expand our system when they have lousy support. Sure hasn't been "World Class" as they claim it is; from what I've seen.

        Comment


        • #5
          It sounds to me like this is a case of Mr. Chavez (who according to LinkedIn is a Lead Engineer at ShoreTel) not "thinking for himself" and instead blindly following bad advice provided by Microsoft.

          Comment


          • #6
            AD Field

            The "correct" field is the one that works for the customer.

            Like Microsoft has never "recommended" anything that was "incorrect" before?

            seriously?

            Comment


            • #7
              Originally posted by pathfinder_nick View Post
              I would agree with Nomad on this. For example, our active directory domain is "pathfinder.local" and our e-mail domain is "pathfinderservices.org". Currently this problem with AD integration is preventing us from using that feature. I have a request open with support on it, but so far they haven't admitted that this is a problem.
              I'm not sure why this is a problem, it works for me. If the ShoreTel server's SMTP service is set to relay through your Exchange server then [email protected]l will still be delivered to your Inbox, right? I have the same setup on our system and I get voicemail notification emails, etc with no problem.

              Also, I agree with the trust of this thread that we should have some choice, but if ShoreTel had chosen better defaults - we wouldn't want the choice.

              Comment


              • #8
                Originally posted by Jason Learmouth View Post
                I'm not sure why this is a problem, it works for me. If the ShoreTel server's SMTP service is set to relay through your Exchange server then [email protected]l will still be delivered to your Inbox, right? I have the same setup on our system and I get voicemail notification emails, etc with no problem.
                That may work if you use Exchange, but not every organization uses Exchange. For example, we use Lotus Notes/Domino.

                Comment


                • #9
                  Plus, when you look in the directory, the email listed is the userPrincipalName. If one of my coworkers wanted to give out my email address, they are going to see the wrong entry for my email.

                  Comment


                  • #10
                    You can set up an alternate UPN suffix in Active Directory Domains and trusts. So if your default domain is: subdomain.domain.com. you can set up an alternate UPN suffix called domain.com and then under account in the AD user properties, you can choose the @domain.com suffix, this will change the userPrincipalName to be [email protected] instead of [email protected].

                    This does not change the way users log in, in fact, it simplifies it.

                    Comment


                    • #11
                      Originally posted by pathfinder_nick View Post
                      That may work if you use Exchange, but not every organization uses Exchange. For example, we use Lotus Notes/Domino.
                      Point taken. LanceB's suggestion regarding the alternate UPN may be a solution.

                      Comment


                      • #12
                        Update-

                        I was advised by support yesterday afternoon that engineering has fixed this issue and will be out in the next build within a couple weeks.

                        Comment


                        • #13
                          Right on. That's what I like to hear.

                          Comment


                          • #14
                            We have a UPN set up so it matches the email address so it wasn't an issue for us either. The other upside to having it this way is that you can tell employees they can log into things like OWA or other domain-enabled resources with email address as their username. Many people are already used to logging into non-work sites that way. It beats telling them DOMAIN\username.

                            Comment


                            • #15
                              I posted this in another thread without a response...

                              So, any idea how to log into the Shoreware Web Access (not director) with AD integration turned on? I've tried (domain\username -> Domain pass) (username -> Domain pass)(Shoretel username -> Shoretel Pass) (email address -> Domain pass)... Nothing seems to be working.

                              Comment

                              Working...
                              X