Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Voicemail Greetings Cancelled

    Having a very weird issue with a customers ShoreTel 14.2 - Build 19.44.7901.0

    On any phone you can pick it up, dial into voicemail, login with password, press 7 for options, and 1 to record greeting. However upon recording the greeting and pressing # (pound) to save results in the prompt "Greeting cancelled" and goes back, never saves the greeting. # works all the way through to get to this point, but just not allowing the greeting to save.

    I've tried rebooting server, rebooting phone, factory restoring a phone, pressing * (to see if it somehow crossed with #), using speaker, using handset, using different phones/extensions, recording a short 1 second message, recording a long message, made sure phone(s) had up to date firmware, and muting the phone to make sure it wasn't a weird DTMF issue with echo, even though # is working to get to the point where it will let you record a message (I just tried it anyway). Voicemail server says it has plenty of space, as well as the server itself on drive C:

    All of this, and still nothing, it won't let us record and save a greeting, it just kicks back with "greeting cancelled" and brings us back. Am completely at a loss as to what could be causing this. As far as I knew there wasn't any settings to even keep a user from making a greeting, and even if there was I would think it would stop the user before even letting them record one.

    If anybody has any knowledge, had this happen to them, or anything I could try at this point, please let me know.

  • #2
    Are all of the services running?
    Randy Wensmann
    [email protected]
    (408) 385-3485
    www.btxchange.com

    Comment


    • #3
      Yes, all services are running, and set to automatic.

      Also thank you for replying back.

      Comment


      • #4
        I would guess that this user might be in a user group that does not allow access to those features.
        Lance Paddock
        BTX | Business Telephone eXchange
        1(800) 289-0299

        Comment


        • #5
          Lance,

          Thank you for posting a reply back. Apologies for replying back so late, I've swamped with tickets these past two weeks.

          Am sorry, but could you be a little more specific as to what features are needed? All users are in the "executives" user group, which as far as I can tell have the most, if not all, features activated. I can't tell directly which features would be causing them not to be able to record greetings. The user group and/or the class of service seems to be correct? So if there is a specific one(s) that I might be missing could you please let me know which one(s)?

          Thank you again.
          Last edited by Artcom_Albert; 02-05-2020, 02:40 PM.

          Comment


          • #6
            If it is a user group permission it would likely be a COS- Voice Mail Permission and the 2 most obvious spots that would prevent recording would be the incoming length and outgoing length. If it is not related to those areas you could have a greater issue in the database or server. Does this happen with all users? Try building a new user and see if they experience the same issue.
            Lance Paddock
            BTX | Business Telephone eXchange
            1(800) 289-0299

            Comment


            • #7
              COS - Voicemail Permissions - Large Mail Box, has the incoming message length set to 480 seconds, and outgoing message length set to 240 seconds. It also does happen with all users, but I haven't tried making a new user yet, I'll give that a shot.

              The really weird thing is, is that if you call in from a cell phone to hit the auto attendant, and then log into voicemail doing it that way, everything works and goes through just fine. The only time it doesn't work is from the phones themselves.

              Thanks again, and I'll post back a reply on if the making a new user works or not. We are in a stand still right now with the customer until their IT comes back from vacation, so it might be awhile until I can test with them.

              Comment


              • #8
                Client IT came back, and I made completely new test User Groups, and test Class of Services, and set all features I could see to have no restrictions, and full access. Then I made completely new users, with no copy's, and set those to two different existing phones, and had him test with those. The issue is still present, and still will not allow the recording to be saved.

                I think at this point, unless there is something else that anybody else can think of, that Lance your statement of the database or server being corrupt is what the issue might be. I will continue to try anything else that anyone can think of, so please let me know.

                Comment

                Working...
                X