Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrading to ShoreTel Connect

    We are upgrading our current ShoreTel Director 14.2, Build 19.49.5200.0 to the new ShoreTel Connect Build 21.87.9727.0 on Windows Server 2008. We passed all the preliminary requirements checks. But when we try to install the new Connect Build, we get the following error:

    Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor. Action CheckDatabase, entry: CheckObsoloeteHAndSWMSI, library: ...\MSI...

  • #2
    Can you confirm that your pre-reqs installed correctly? I mean the Microsoft Visual C++ 2015, etc that installs prior to actually initiating the upgrade process? I've noticed at least on Server 2016, the installer will report that it "succeeded" but actually fails if you don't have the correct Windows updates. It will even show in the programs and features section as installed. Try to install the pre-reqs one at a time in the pre-req folder that comes with the build. If it errors out you'll see why. You could probably also look through the event viewer and find whether the pre-reqs installed correctly.

    Comment


    • #3
      Oh, and make sure your 2008 server is on SP1, that will break stuff for sure if it's not.

      Comment


      • #4
        Thanks Augie! Are you talking about all the installs in the ISSetupPrerequisites folder as seen in this screenshot?

        Comment


        • #5
          Yes exactly, search through those folders until you find the Microsoft Visual C++ 2015 stuff (I think there will be a x32 and x64 bit that gets installed). Make sure those install correctly.

          Comment


          • #6
            It looks like I am good on the C++ installs

            Comment


            • #7
              I literally just did one of these upgrades the other day, here's my list of pre-reqs. Can you uninstall Visual 2015 both x32 and x64 and install the versions that come in the pre-req folder?

              Did you say you had service pack 1 installed?
              Attached Files

              Comment


              • #8

                Comment


                • #9
                  I would uninstall those 2015 versions and manually install the ones in the pre-req folder to make sure you visually see them install correctly. I've seen this where they show up in programs and features but they didn't install successfully - the DLLs didn't make it to a specific Windows folder directory - which causes the installer to bomb.

                  Comment


                  • #10
                    so Mitel gave us some IIS scripts to run during our upgrade so it appears to be an IIS version issue. We will find out tonight when we try the upgrade again.

                    Comment


                    • #11
                      Hmm for Server 2008?? That was only applicable to Server 2016...

                      I think they bamboozled you...
                      Last edited by augie; 06-21-2018, 11:10 AM.

                      Comment


                      • #12
                        If I'm in a scenario like this in the middle of the night, and I've got no options - I'll grind it out until I figure out the problem, but sometimes it's easier to just spin up a newer server, install software, then migrate, then upgrade. Ever thought of moving up to Server 2012R2, or even Server 2016? Just beware there's a few gotchas on Server 2016 right now.

                        I suppose if you wanted to do Server 2016 you'd need to get to Connect first...

                        Comment


                        • #13
                          Yes, we are actually moving to Server 2016, however, was told we had to upgrade the current ShoreTel 14.2 to Connect while still on Server 2008 then move the upgraded Connect over to Server 2016 from 2008. We already have the Server 2016 machine ready to go, just waiting on the upgrade to Connect.

                          Comment


                          • #14
                            Slowly getting through different errors. So I am now stuck with the following error. Any ideas?

                            Comment


                            • #15
                              That looks like an incompatible installer error. Are you trying to use Build 21.87.9727.0?
                              Last edited by Lance; 06-22-2018, 09:25 AM.
                              Lance Paddock
                              BTX | Business Telephone eXchange
                              1(800) 289-0299

                              Comment

                              Working...
                              X