Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Shoretel Connect - Populate Server

    is there anyway to pre-populate the server for shoretel connect so employees dont have to guess what it is?

  • #2
    I've been reading your question over and over to try to understand what it is you are asking. You've been using Shoretel for quite a while, so you don't mean how do you enter users or assign phones before the system goes live, and I don't think you are asking how to get the phones to connect to the server without having to manually configure them.

    So please, what do you mean by pre-populate connect and what is it that your users are guessing about?

    Comment


    • #3
      Im talking about the desktop app.

      With shoretel communicator (14.2 and earlier) i had registry values populate through active directory to enable Integrated windows authentication, set the server and all the other settings a user would need to know to configure shoretel communicator

      However with connect (15.x) i cant seem to figure out how to per-populate these settings.

      Shoretel Connect starts with all the fields blank and the user must have knowledge of the server address to be able to login. I constantly get calls from people asking me how to setup their shortel when they switch desks.

      Is there anyway to have all or some (server field) populated

      Comment


      • #4
        (sorry i read my message again and i can see how it could be confusing)

        Comment


        • #5
          install the connect client, populate the fields and login, then find the necessary fields in the registry and use a GPO to push them to users after the client is installed?

          Comment


          • #6
            Originally posted by bhaikalis View Post
            install the connect client, populate the fields and login, then find the necessary fields in the registry and use a GPO to push them to users after the client is installed?
            A quick test ... I found the keys under "HKEY_CURRENT_USER\Software\ShoreTel\Client" as well as "HKEY_USERS\{}{}\Software\ShoreTel\Client" (user number redacted).
            I created the following .reg file, uninstalled Connect and removed the registry key that lingered.
            Then I ran the ,reg file to add the keys to the default user and reinstalled Connect.
            The server populated. (I was also able to populate the username but I'm not sure I'll use that in production as computers can move.)

            Code:
            Windows Registry Editor Version 5.00
            
            [HKEY_USERS\.DEFAULT\Software\ShoreTel\Client]
            "ServerName"="connect"
            "Server"="connect"
            If this works it will help ... especially since the server name block is hidden as an "advanced" option that people do not see unless they follow instructions to click on advanced. (What? All of your users follow instructions? If they did that they would all be typing the correct server name. )

            Comment


            • #7
              I tried doing this already. I have those fields in my GPO being pushed already but they don't seem to work


              ServerName,Server, Username


              I found I had to delete C:\Users\%username%\AppData\Local\shoretel to "reset" the settings for a user. So thats where they are stored in some sort of datafile.

              Comment


              • #8
                The easiest way is to create a SRV record (Service Location) in your DNS:
                under the _tcp tree create a record named "_shoretel-connect" and point it at the address of your server. Depending if you are using SSL or not you can specify port 443 or 80 in the record

                The knowledge base article is located here: https://oneview.mitel.com/s/article/...t-Client-Login

                Comment


                • #9
                  Originally posted by darkdrgn2k View Post
                  I tried doing this already. I have those fields in my GPO being pushed already but they don't seem to work


                  ServerName,Server, Username


                  I found I had to delete C:\Users\%username%\AppData\Local\shoretel to "reset" the settings for a user. So thats where they are stored in some sort of datafile.
                  The .DEFAULT keys would only work if the user had not ever run Connect (which is where I see the problem ... people who change computers or share computers needing to log in to Connect for the first time). Changing the server name from one server to another for an existing user is a more complicated problem.

                  Comment


                  • #10
                    Originally posted by ericdbarth View Post
                    The easiest way is to create a SRV record (Service Location) in your DNS:
                    under the _tcp tree create a record named "_shoretel-connect" and point it at the address of your server. Depending if you are using SSL or not you can specify port 443 or 80 in the record

                    The knowledge base article is located here: https://oneview.mitel.com/s/article/...t-Client-Login
                    I need to give that a look. It certainly would help to have clients not need the server name entered manually.

                    BTW: I have a Connect ONSITE system,
                    Last edited by justalurker; 04-04-2018, 01:16 AM.

                    Comment


                    • #11
                      Originally posted by justalurker View Post
                      I need to give that a look. It certainly would help to have clients not need the server name entered manually.

                      BTW: I have a Connect ONSITE system,
                      We have Connect Onsite as well. I tried playing around with registry keys and GPO with no success. The SRV record has worked well.

                      Comment


                      • #12
                        For me the CONNECT client does not populate the server until "windows authentication" is checked then unchecked. Only then does the server field get populated.

                        Then it has to be checked again as we use windows auth.

                        so wierd.

                        Comment

                        Working...
                        X