Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Softphone and USB Dect headsets

    We are using the latest and greatest build of ShoreTel Connect
    Connect Client Build 213.100.2558.0
    When assigned to softphone, the USB headset does not play audio, have tried with a variety of different cordless (DECT) headsets including:
    Plantronics
    Jabra
    Sennheiser

    None of the will play audio from ShoreTel, but the Windows sounds play OK.
    Using a USB corded headset such as a Plantronics Audio 478 USB works OK.

    I rolled back to an older build of the Connect Client and audio works on all the headsets above, the problem appears to be when using build 213.100.2558.0

    Looking at a wireshark trace while making a call with one way audio shows that there is traffic in both directions so it feels more like there is a problem interfacing the application with the WIndows audio layer.

  • #2
    We had the same experience using the Jabra headsets, had to downgrade the client to 213.100.2163 for the Jabra headset to work (i beleive the plantronics ones were working though)

    Comment


    • #3
      We are having similar issues with 213.100.2453.0 and Plantronic Savi 420s. Only sure fire workaround I have found is 1 Set the headset as Default audio device (not just default Communications)
      2 In plantronics Hub settings have the connection as always active, in Softphone set the Media Play action to "Do Nothing" and in ringtones and volumes, set the ringtone location to all devices.
      my theory is that for what ever reason Windows treats as an Media Application rather than a Communications app. (hence the setting Media Play action to "Do Nothing") YMMV

      Comment


      • #4
        There is another workaround. If you dig about in the mixer settings playback devices, look at the properties for your headset audio device, There is a tab labelled "Advanced" and in there you can choose an audio quality format for "Tape Quality" which seems to resolve it.
        Its not a realistic solution if you have hundreds of Softphone users.

        http://www.plantronics.com/us/suppor...%26region%3Dus

        Comment


        • #5
          Originally posted by PacketPlumber View Post
          We are having similar issues with 213.100.2453.0 and Plantronic Savi 420s. Only sure fire workaround I have found is 1 Set the headset as Default audio device (not just default Communications)
          2 In plantronics Hub settings have the connection as always active, in Softphone set the Media Play action to "Do Nothing" and in ringtones and volumes, set the ringtone location to all devices.
          my theory is that for what ever reason Windows treats as an Media Application rather than a Communications app. (hence the setting Media Play action to "Do Nothing") YMMV
          How can we get windows to recognize Connect Client as a Communications app? That is the problem with me because my Jabra Direct Dashboard does not recognize Shoretel as being ready - so none of the remote call buttons work since Jabra cant communicate with Connect as a communications device. Any idea how to support the link between Jabra Dashboard and Connect?

          Comment


          • #6
            Originally posted by jogdenleo View Post

            How can we get windows to recognize Connect Client as a Communications app? That is the problem with me because my Jabra Direct Dashboard does not recognize Shoretel as being ready - so none of the remote call buttons work since Jabra cant communicate with Connect as a communications device. Any idea how to support the link between Jabra Dashboard and Connect?
            Sorry for the late reply, But you'll need to have the TAPI drivers installed to get the Jabra software to work. if they are connect via and Edge Gateway, you're kind screwed because the edge doesn't play well with the TAPI at all. It has been a MAJOR pain in our backside.

            Comment

            Working...
            X