Announcement

Collapse

Welcome to ShoreTelForums.com

Welcome to ShoreTelForums.com!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel/Mitel systems. ShoreTel/Mitel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel/Mitel, Inc. although you may find ShoreTel/Mitel employees sharing there experiences and expertise. If you would like more information on ShoreTel/Mitel systems, contact BTX at [email protected]

As always please support the advertisers that help support our site.

Thank You,
BTX
See more
See less
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Adding DHCP option 156 and option 4 to Cisco Router

    If you are using a Cisco Router as a DHCP server, you can still set it to offer option 156.

    Within the 'DHCP Pool'
    add this:
    option 156 ascii "ftpservers=192.168.1.x, country=1, language=1, layer2tagging=0, vlanid=0"

    If you want to add DHCP option 4 (SNTP time server)
    add this:
    option 4 ip 131.107.1.10 (or IP of your Time Server)

  • #2
    This just goes to show that I should check this forum more often. I ran into this issue the other day and it took me some time to get through. We had a problem for some reason with the option 4. The Cisco routher showed it was locked with a time source in Chicago and was showing Central Time (we are in Minnesota) and was in daylight savings mode, however the ShoreTel phones were 1 hour off. We eventually made an entry in the custom file for the 230 and 560 phones (sbbcustom and s6custom I think) and entered snmp 192.168.1.X or whatever your time server is and that worked too.

    Comment


    • #3
      Option 156 on a Cisco 1841 router ver 12.4

      I'm installing a similar configuration from posts on this forum about using DHCP on a Cisco router....


      ip dhcp pool Shoretel
      network 192.168.5.0 255.255.255.0
      default-router 192.168.5.1
      option 4 ip 192.168.0.15
      dns-server 192.168.0.5
      option 156 ascii "ftpservers=192.168.0.15, country=1, language=1, layer2tagging=0,vlanid=0"
      option 2 hex ffff.8f80

      ip dhcp excluded 192.168.5.1 192.168.7.50


      With option 156 in the configuration, DHCP doesn't work and the phones do not recieve an IP until I remove it from the configuration.

      Does anyone know if the option is limited to certain routers?

      Comment


      • #4
        Originally posted by Brian
        I'm installing a similar configuration from posts on this forum about using DHCP on a Cisco router....


        ip dhcp pool Shoretel
        network 192.168.5.0 255.255.255.0
        default-router 192.168.5.1
        option 4 ip 192.168.0.15
        dns-server 192.168.0.5
        option 156 ascii "ftpservers=192.168.0.15, country=1, language=1, layer2tagging=0,vlanid=0"
        option 2 hex ffff.8f80

        ip dhcp excluded 192.168.5.1 192.168.7.50


        With option 156 in the configuration, DHCP doesn't work and the phones do not recieve an IP until I remove it from the configuration.

        Does anyone know if the option is limited to certain routers?
        You are putting the phones into VLAN 0 which is probably not configured... What VLAN are your phones supposed to be in? You have also turned off layer 2 tagging which you should keep on if you are using VLANs.

        Comment


        • #5
          Originally posted by Charles
          If you are using a Cisco Router as a DHCP server, you can still set it to offer option 156.

          Within the 'DHCP Pool'
          add this:
          option 156 ascii "ftpservers=192.168.1.x, country=1, language=1, layer2tagging=0, vlanid=0"

          If you want to add DHCP option 4 (SNTP time server)
          add this:
          option 4 ip 131.107.1.10 (or IP of your Time Server)
          If you are not using VLANs I believe you should set the vlanid to 1 which is the default vlan in cisco....

          Comment


          • #6
            Your could try adding the older 66 option for the ip 100 and dropping the 156 if you don't need vlan tagging.

            option 66 ascii "192.168.1.10" would be the format. I know it still worked for the 530/560/110 under 6.0. I never tried it with a 230. But that does not mean they will support it forever.

            As for the option 156 I don't think 0 is the null value. It may be "null" or just nothing at all. You might try play around with different values for null.
            Last edited by aspen; 02-22-2007, 01:49 PM.
            There are 10 types of people in the world, those that understand binary and those that donít.

            Comment


            • #7
              Could it be the dhcp excluded statement? Is that a range or list? why the 7?

              Comment


              • #8
                Originally posted by tnshurtm
                Could it be the dhcp excluded statement? Is that a range or list? why the 7?
                That's a good eye...

                ip dhcp excluded 192.168.5.1 192.168.7.50

                this would exclude the entire 192.168.5.1 - 192.168.7.50 RANGE from being issued.

                Originally posted by Cisco
                Issue the ip dhcp excluded-address command to exclude IP
                !--- addresses from being assigned by the DHCP server.
                Wonder if it's just a typo.

                Charles

                Comment


                • #9
                  Found a solution

                  Originally posted by Brian
                  I'm installing a similar configuration from posts on this forum about using DHCP on a Cisco router....


                  ip dhcp pool Shoretel
                  network 192.168.5.0 255.255.255.0
                  default-router 192.168.5.1
                  option 4 ip 192.168.0.15
                  dns-server 192.168.0.5
                  option 156 ascii "ftpservers=192.168.0.15, country=1, language=1, layer2tagging=0,vlanid=0"
                  option 2 hex ffff.8f80

                  ip dhcp excluded 192.168.5.1 192.168.7.50


                  With option 156 in the configuration, DHCP doesn't work and the phones do not recieve an IP until I remove it from the configuration.

                  Does anyone know if the option is limited to certain routers?
                  I found that the small Cisco 1700 router I was trying to configure for DHCP could not handle all of those lines. I removed "option 2 hex ffff.8f80" and it worked like a charm... I'm thinking it had to do with placing too much on the router to issue out all of those lines...

                  Thanks for all of the great suggests. I hope this helps some one else.

                  Comment


                  • #10
                    Option 4 or Option 42

                    Is there a difference in option 4 and option 42. I have always used 42, as i was looking for an actual NTP. Advice?

                    Comment

                    Working...
                    X
                    😀
                    🥰
                    🤢
                    😎
                    😡
                    👍
                    👎