Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wrong Time on IP phones

    When I do a new install, the phones donít show up the right time. After doing a wireshark trace, I can see the NTP packets are going through the switch to the phones, but the phones donít accept the right time from the DHCP server(option 42 and option4 are both configured correctly on DHCP server). The phone show an initial date of Feb 6, I have rebooted the DHCP server, phone server, phone switches and IP phones, but no luck.

  • #2
    Sounds like it should be working. The only thing I could suggest is to ensure that the NTP server addresses you entered into the DHCP server are working. Internet time servers are notoriously slow and unresponsive. When I set our phones up I had to check several servers before I found some that responded in a timely fashion.

    Comment


    • #3
      I prefer to get time from a domain controller or other source on the LAN for the reasons that LonnieBear described.

      Comment


      • #4
        Have you checked to make sure the site has the correct Time Zone?

        Comment


        • #5
          Time Zone is a good suggestion. If that doesn't work then I'd check the phone to see what time server it is trying to connect to.

          Comment


          • #6
            DHCP servr option 4 and option 42 are configured on the Shoretel Phone server to give out IP addresses and also the time in the scope.
            The Shoretel Phone server (Windows 2003) is getting time internet (time.windows.com)

            The zone is also correctly set. Can someone suggest where can I change the Stratum level on the Shoretel Phone Server. Thanks

            Comment


            • #7
              Make sure that the router ip address (option 3) is configured correctly as well. It should be the same as the "gateway" IP address that is shown by ipconfig on any of the pc's that has internet access.. I had the same problem when I first setup our office phones.

              -Jack Smith
              Last edited by jrsmith1279; 03-27-2008, 06:45 AM.

              Comment


              • #8
                Ntp

                Is this something that was working and stopped, or something that has never worked?

                If you are pointing to your Voicemail/Shoretel server for NTP time you have to be running/allowing NTP server functions on that server. I do not believe they are on by default.

                You also have to make sure the phones can access the server on port 123 UDP

                HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\W32Time\Parameters registry subkey.
                From the Edit menu, select New, DWORD Value.
                Enter the name LocalNTP, then press Enter.
                Double-click the new value, set it to 1 to enable or 0 to disable, then click OK.
                Restart the computer for the change to take effect.


                http://www.spy-hill.com/~myers/help/...s/W32Time.html

                net time /setsntp: will allow you to set which external servers you want to pull time from on the shoretel server.

                gary
                Last edited by eazeaz; 03-27-2008, 07:18 AM.

                Comment


                • #9
                  Hi eazeaz

                  Can you pl tell how to make allow NTP server functions on that server?

                  I have enabled DHCP options 42 and 4 on the server.

                  Do I have to do anything else. Where do I have to enable
                  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\W32Time\Parameters registry subkey

                  Thanks

                  Comment


                  • #10
                    We use ATS (Absolute Time Server) program on the ShoreTel server, which pumps the time out to the phones via NTP.
                    -LC

                    Comment


                    • #11
                      NTP Server

                      Open Regedit

                      Browse to the

                      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\W32Time\Parameters

                      section

                      Create/Modify a DWORD entry that says

                      LocalNTP

                      Give it a decimal value of 1

                      reboot

                      That should work for you

                      gary

                      Comment


                      • #12
                        Screenshot

                        NTP Screenshot
                        Attached Files

                        Comment


                        • #13
                          Thanks to everyone who replied.

                          Solution: Pointed to a server that pushes out time. Shoretel Phone server does not by default sends time.

                          Comment


                          • #14
                            Where do you guys find these NTP servers?

                            Comment


                            • #15
                              It really does work quite well

                              Originally posted by mirey View Post
                              We use ATS (Absolute Time Server) program on the ShoreTel server, which pumps the time out to the phones via NTP.
                              I was having similar troubles with SHoreTel phones not showing correct time. So I used ATS to great success!

                              Stupid Windoze Time does not work.

                              Comment

                              Working...
                              X