No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Port 5060

    I am doing some test with Sip trunking. How to I enable the Shoretel (7.5) system to listen on port 5060?

    Thanks, Charles

  • #2
    From Shoretel:

    There are no special network requirements necessary for deploying SIP. The general system requirements should prove adequate for SIP support.

    Please note the following:

    • SIP devices are supported behind NAT(Network Address Translation) as long as they are configured statically.
    • To communicate with a SIP device or service provider providing IP trunks over the Internet, you must be able to pass SIP traffic through your firewall. This requires a SIP application layer gateway – a feature typically provided by most firewall vendors.
    • SIP signaling uses UDP port 5060.
    • When using SIP, the RTP port is dynamic and the SIP endpoints may not always use the same ports to exchange information (in contrast with ShoreTel’s proprietary protocol, which always uses port 5004). Thus, if you are using SIP, you must deselect the “Always Use Port 5004 for RTP” check box on the Call Control Options page in Director so that it is not fixed at 5004.
    Don't forget to reboot switches and phones after changing this setting!!!


    • #3
      Hi Charles,

      In this setup, we are actually passing the sip traffic via a vpn. Do I need to create any special rules for this? I know I would if it were through the public internet, but I am not sure since it is via the vpn tunnel.

      I have already done the steps above. However, I never see port 5060 when I run a port moniter on the shoretel server. Nor does any connection occur.

      I do see the following with WireShark:
      30 0.665338 ICMP Destination unreachable (Port unreachable)