Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PCM Setup on XP SP2

    I'm having a small problem with getting the PCM up and running on an XP SP2 workstation. The software install runs without any errors. After the reboot when trying to authenticate the user for the first time is where the fun begins. I enter the users credentials and the server name. The window pops up with the little key dutifully marching toward the server...for less than a second...then it drops me right back to the authentication screen. The user name and password are good (I use them to log onto the Director daily as this happens to be my own workstation thats causing the fuss ). I can ping the server from the workstation by name. At one point PCM was installed on the workstation in question, but was uninstalled. I've been through the registry and removed all references to anything ShoreTel. I'm hoping someone may be able to point out the something (probably obvious) that I'm overlooking.

    Any thoughts or suggestions would be greatly appreciated.

    Thank you

  • #2
    Check the Windows Firewall to make sure it is not enabled.

    Comment


    • #3
      The firewall is disabled.

      Comment


      • #4
        try this:
        in registry go to CU/software/Shoreline Teleworks <-delete that
        retry it

        Comment


        • #5
          I'll give that a try and post the results.

          Thank you

          Comment


          • #6
            if that does not work try this:
            (you need to attempt to log in once for the registry keys to create)

            Make sure ShoreTel is closed on the computer you are working on. Under task manager make sure these 2 processes are not running:
            CSISCMGR.exe
            STCHost.exe

            in registry go to CU/software/Shoreline Teleworks/
            inside that create these registry keys.

            Create a reg key “Reg_Multi_SZ” named “OwnedDNs” with the users extension for the data (ex 1234)

            Create “Reg_SZ” named “Password” and enter in data “4cb9c8a8048fd02294477fcb1a41191a” (make sure the password is set to “changeme” on the shoretel system or find the MD5 hash for the current password)

            Create “Reg_SZ” named “Server” with your server ip (ex 192.168.1.1)

            Finally create “Reg_SZ” named “UserName” and enter the users login name for the CM.

            Open CM and see if it works.

            This is only meant to help troubleshoot and is not a fix.

            Comment


            • #7
              Also check in control panel - Phone and modem - the advanced tab there should be a "ShoreTel Remote TAPI Service Provider" item in there. Do you have that?

              Comment


              • #8
                All of the data being entered into the appropriate keys resulted in the PCM launching, but with an icon in the lower right corner of the window "No TAPI line device for your extension", and an icon in the systray "Cannot connect to ShoreWare Server"

                The ShoreTel Remote TAPI Service Provider appears twice under the Advanced tab of the Phone and Modem properties. Both instances show "NULL" in the "Server" and "login" fields. I ran through the instructions in the Maint Guide, but the only way I could make a connection to the server was to check the "Application Server" box. At that point I retried the PCM, but there was no change. I tried rebooting, confirmed the configuration information in the ShoreTel Remote TAPI Service Provider, and relaunched the PCM. No joy.
                Last edited by DCapen; 08-29-2007, 10:52 AM.

                Comment


                • #9
                  delete both TAPI's and follow these instructions.
                  Close ShoreTel and make sure the 2 processes are stopped as noted before.

                  copy a file from your voicemail server called TspInstall.exe
                  (location should be x:\Program Files\Shoreline Communications\ShoreWare Server)
                  If not search for it.

                  copy that to the computer you are working on

                  open command prompt

                  go to the location of that file in the command window

                  type in:

                  TspInstall.exe –i StClient
                  (this is what is suppose to setup when CM is installed)

                  Try it. If does not work restart and try it. If it still does not work delete the TAPI out of “phones and modems” try this:

                  In command prompt in the directory of the TspInstall.exe type:

                  TspInstall.exe –I StServer (then your vm server ip)
                  (Ex “TspInstall.exe –i StServer 192.168.1.1”)

                  Retry ShoreTel if still does not work (close ShoreTel CM) go into the “phone and modem” open the ShoreTel TAPI and make sure the Login: says “ShoreTel” and Server: says DNS of VM or IP of voicemail. Then check mark the Application Server box. Hit ok then restart and try again.

                  Now this is a terminal server setup. I have done this to a couple computers on our network that would get the no TAPI device located error. Seems to cause no problems and fixed it. Also this is not a ShoreTel fix; this is something that I put together, so this might not be the way to permanently fix this problem.

                  Comment


                  • #10
                    All of the above tried, still no joy. I guess it just wasn't meant to be...
                    Last edited by DCapen; 08-29-2007, 02:51 PM.

                    Comment


                    • #11
                      I went through the same thing

                      I had a similar issue happen to me at one site, the cause was my Internet Explorer proxy settings. Once I added the shoretel server's ip address in to the exception list it fixed it.

                      This is only for those using a proxy server.... hope this helps someone else not spend hours trying to figure out that pcm is highly tied to IE.

                      Jack L

                      Comment


                      • #12
                        We do use a proxy server, and it was set up in the bypass. I can connect to the client install web page on the server without any problems, and installs performed on other XP workstations in the same subnet went off without a hitch. I guess I'll just have to content myself with all of the end users being up and running, which is sad since I considered the PCM one of the only redeeming features of the system from an end users perspective...

                        Comment


                        • #13
                          Thanks Jackl!
                          The proxy settings fixed it here.
                          Dave.

                          Comment

                          Working...
                          X