Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Phone rings but now voice

    Hi guys...i am new to the Shoretel world...we are testing the Shoretel phone system on our network. We have a cisco 6500 core/dist switch and the access switches are Cisco 3560. The Shoreware Director and SG30 phone switch are on the VLAN 172. I have setup vlan 10 for data and vlan 20 as voice. I have enable option 156 on the DHCP server scope. My pc are tie to the phone (560g). Here is my problem...

    The phone boot up fine to the correct voice vlan and obtain all of it config from the ftp server. My pc is up and running on the correct vlan too. i also get dial tone. The problem i have is when i make a phone call to another shoretel phone with the same setup, it rings....but when the other end pickup the call, their is no sound. We can not communicate. I can't figure out what is causing this...i read some where that it could be related to qos traversing vlans. Can anyone help?

  • #2
    OK, but the phones are on the same VLAN, correct? So the only traversing vlans is the call setup by the ST switch, which apparently is working...

    So...Do you have the handset plugged into the right jack on the phone? Have you tried talking on speakerphone?

    Otherwise, it sounds like a routing problem, so I would make sure the phones are actually on the right VLAN, have the right gateway, etc...

    Comment


    • #3
      Originally posted by Bobby_Digital View Post
      OK, but the phones are on the same VLAN, correct? So the only traversing vlans is the call setup by the ST switch, which apparently is working...

      So...Do you have the handset plugged into the right jack on the phone? Have you tried talking on speakerphone?

      Otherwise, it sounds like a routing problem, so I would make sure the phones are actually on the right VLAN, have the right gateway, etc...

      Yes, the handset are plugged into the right jack on the phone.....i can ping the phone ip that it gets from the voice vlan from the data vlan and also the the vlans that the SG30 switch and Shoreware Director are on.

      Comment


      • #4
        And theres no firewall right? Just the core switch?

        I would think that ports are being blocked.

        Comment


        • #5
          I know this may be a bit redundant but have you ran a wireshark trace yet. If not i suggest you do. Wireshark is a very valuable tool to use and figure out these problems. You could see the call set up and all. If you run a trace on a known good phone you will be able to figure out what is NOT happening, now your cooking with oil. If you need any help, holla at me.

          400Degreez....take two of these and walk it out!

          Comment


          • #6
            Here is what i am seeing...the two phones can ping the SG30 switch and ping the Shoreware Director...The problem is, the two phone can not ping each other...the phones are sitting on the same vlan within the same subnet. Both phones can ping the default gateway. It can ping anything and everything within our network...but it just can't ping each other with the same vlan. There is not ACL on the vlan neither.
            Last edited by Ckhen; 10-26-2009, 01:39 PM. Reason: adding more notes

            Comment


            • #7
              Are the phones connected to the same Cisco switch, or are they connected to two different switches?

              Comment


              • #8
                The two phones and SG30 switch are on the same vlan (vlan 700). Vlan 700 is the voice vlan. The shoretel server reside on different vlan (vlan 172).

                The phone are connected to the same L3 switch (Cisco 65xx).

                Here are what working:

                1.)Both phones can call each other and the phone will rings.
                2.)Both phones can access voicemail and leave voice mail on each other inbox.
                3.)Both phones can ping the SG30 switch and the shoreware director server.
                4.)Both phone can ping anything within the internal network of the company.
                5.) The phone can ping their default-gateway of that vlan that they are on.

                Here are what not working:

                1.)When you call the other phone, it will ring, but when you pickup the call, there is dead silence.
                2.) The phone are on the same subnet/vlan, but they can not ping each other.

                Comment


                • #9
                  Post the running configs from your switches. You can strip out key identifying information if you like.

                  Comment


                  • #10
                    Here is a partial config of my L3 Cisco 6500...Both phones and SG30 switch and the Shorewae director are hanging off the 6500 physically...but separated by vlans.


                    Config: The switch port that the phone are doing dot1q trunk...but you don't see that because it by default and it's the only trunk encapsulation that the WS-X6548-GE-TX module of the 65xx can do. I have verify that with Cisco.

                    !
                    version 12.2
                    service tcp-keepalives-in
                    service timestamps debug datetime localtime show-timezone
                    service timestamps log datetime localtime show-timezone
                    service password-encryption
                    service counters max age 10
                    !
                    hostname PLANOTXCAMPUSA
                    !
                    boot system flash sup-bootflash:
                    boot system flash disk0:
                    logging snmp-authfail
                    logging buffered 150000 debugging
                    no logging console
                    !
                    aaa new-model
                    aaa authentication login default group tacacs+ enable
                    aaa authentication enable default group tacacs+ enable
                    aaa accounting commands 15 default stop-only group tacacs+
                    !
                    aaa session-id common
                    clock timezone CST -6
                    clock summer-time CDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
                    vtp domain denbury
                    vtp mode transparent
                    ip subnet-zero
                    no ip source-route
                    !
                    ip name-server 172.16.4.125
                    !
                    no ip bootp server
                    ip multicast-routing
                    mls ip multicast flow-stat-timer 9
                    mls flow ip destination-source
                    no mls flow ipv6
                    mls qos map cos-dscp 0 8 16 26 32 46 46 56
                    mls qos
                    mls cef error action freeze
                    !
                    spanning-tree mode rapid-pvst
                    spanning-tree loopguard default
                    no spanning-tree optimize bpdu transmission
                    spanning-tree extend system-id
                    spanning-tree vlan 1-2,40,172-174,300,400,500,600,700,800 priority 24576
                    spanning-tree vlan 100,200,900 priority 28672
                    port-channel load-balance src-dst-port
                    diagnostic cns publish cisco.cns.device.diag_results
                    diagnostic cns subscribe cisco.cns.device.diag_commands
                    !
                    redundancy
                    mode sso
                    main-cpu
                    auto-sync startup-config
                    auto-sync running-config
                    auto-sync config-register
                    auto-sync standard
                    !
                    vlan internal allocation policy ascending
                    vlan access-log ratelimit 2000
                    !
                    vlan 172
                    name V_172_Servers_172-16-04-00/22
                    !
                    !
                    vlan 400
                    name V_400_Data_172-16-03-00/24
                    !
                    vlan 700
                    name V_700_Voice_Nwk_192-168-200-00/24
                    !
                    !
                    vlan 999
                    name V_999
                    !

                    !
                    interface GigabitEthernet3/10
                    description Greg Shoretel Phone + PC
                    no ip address
                    load-interval 30
                    mls qos trust extend
                    mls qos trust dscp
                    switchport
                    switchport trunk native vlan 400
                    switchport mode trunk
                    !
                    !
                    interface GigabitEthernet3/14
                    description Dave Shoretel Phone + PC
                    no ip address
                    load-interval 30
                    mls qos trust extend
                    mls qos trust dscp
                    switchport
                    switchport access vlan 400
                    switchport trunk native vlan 400
                    switchport mode trunk
                    !
                    !
                    interface GigabitEthernet10/14
                    description Connect to ShoreTel Switch SG30 - 192.168.200.199
                    no ip address
                    load-interval 30
                    mls qos trust dscp
                    switchport
                    switchport access vlan 700
                    switchport mode access
                    spanning-tree portfast disable
                    spanning-tree bpdufilter disable
                    !
                    !
                    !
                    !
                    interface Vlan172
                    description VLAN-172 Server Segment (172.16.4.0/22)
                    ip address 172.16.4.1 255.255.252.0
                    ip pim sparse-dense-mode
                    load-interval 30
                    standby 1 ip 172.16.4.3
                    standby 1 priority 102
                    standby 1 preempt
                    standby 1 track GigabitEthernet13/3
                    !
                    !
                    !
                    interface Vlan400
                    description Data Vlan (172.16.3.0/24)
                    ip address 172.16.3.1 255.255.255.0
                    ip helper-address 172.16.4.125
                    ip pim sparse-dense-mode
                    load-interval 30
                    standby 1 ip 172.16.3.3
                    standby 1 priority 102
                    standby 1 preempt
                    standby 1 track GigabitEthernet13/3
                    !

                    interface Vlan700
                    description Siemens VoIP VLan
                    ip address 192.168.200.1 255.255.255.0
                    ip helper-address 172.16.4.125
                    load-interval 30
                    standby preempt
                    standby 1 ip 192.168.200.3
                    standby 1 priority 102
                    standby 1 track Vlan700
                    !

                    Comment


                    • #11
                      Port 10 does not have anything defined for switchport access but port 3/14 but port 10/14 has switchport access defined on vlan 400. Put 3/14 on vlan 400 - but I see that is setup as your data vlan. Once you get that setup between the phones and establish communication the next step is to segment your voice and data vlans as you started to setup so that the phones go to the voice vlan and your computer on the data vlan. I see that you're running VTP, is this switch/device in VTP server or VTP client mode?

                      Comment


                      • #12
                        switch vtp are in Transparent mode.

                        Comment


                        • #13
                          Did you apply this command -- switchport access vlan 400 -- to interface 3/10? What was the result?

                          Comment


                          • #14
                            6500 RP sparse mode

                            CKhen - I think you have left out some key informaiton in your post that would be of interest to all. It is my understanding that you are also running the ShoreTel on true access layer switches, namely 3560 class machines. I also understand that calls set up between phones on the 3560 work just fine; further that phone calls between the 3560 and the 6500 also work. The only calls thata do not work are calle between ports on the 6500 blade. I note that you are set up for Mutlicast RP router in your 6500 using ip sparse mode; You are not shooting a vlan problem; you are shooting a media stream problem, and to the 6500 the shoretel media stream looks like a multicast. A packet capture here is what needs to be done. The 6500 is typically set up as a core level router resouce and here you are using at least one blade for ShoreTel phones at the access level. Please confirm your 6500 IOS version and the IOS version of the 3560.

                            Additonally, your config has at least one error in it that could be an issue if my asumptions are correct: the ports for the two phones on 3/10 and 3/14 are configured differently.

                            switchport trunk native vlan 400 ---- should not need this

                            I would also hard set the encapsulation, the way it is in your configuration the 6500 is going to always try isl first. Not sure of the code set but dot1q is not always the default it is normally isl.
                            Last edited by drvoip; 11-11-2009, 01:30 PM. Reason: typeo

                            Comment


                            • #15
                              [QUOTE=drvoip;13639]CKhen - I think you have left out some key informaiton in your post that would be of interest to all. It is my understanding that you are also running the ShoreTel on true access layer switches, namely 3560 class machines. I also understand that calls set up between phones on the 3560 work just fine; further that phone calls between the 3560 and the 6500 also work. The only calls thata do not work are calle between ports on the 6500 blade. I note that you are set up for Mutlicast RP router in your 6500 using ip sparse mode; You are not shooting a vlan problem; you are shooting a media stream problem, and to the 6500 the shoretel media stream looks like a multicast. A packet capture here is what needs to be done. The 6500 is typically set up as a core level router resouce and here you are using at least one blade for ShoreTel phones at the access level. Please confirm your 6500 IOS version and the IOS version of the 3560.

                              Additonally, your config has at least one error in it that could be an issue if my asumptions are correct: the ports for the two phones on 3/10 and 3/14 are configured differently.

                              switchport trunk native vlan 400 ---- should not need this

                              I would also hard set the encapsulation, the way it is in your configuration the 6500 is going to always try isl first. Not sure of the code set but dot1q is not always the default it is normally isl.[/QUOTE

                              The good Doc has a point!

                              Comment

                              Working...
                              X