No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Shoretel IP 530 Phone sends RTP to port 5004


    I have a Shoretel 60/12 using it for SIP. I can place a call but get not AudioOutbound from the Shoretel 530 phone.

    The Phone is sending RTP to my Gateway on port 5004..

    How do I disable it on the Phone so it uses the Port that the ShoreTel Switch receives in the SIP INVITE(SDP) msg from our SBC?

    Under Call Control Options The setting “Always use Port 5004 for RTP” is unchecked, I even rebooted the Phone, Shoretel director and shoregear Switch once.

  • #2
    What version of Shoretel are you running on your Director server?


    • #3
      Shoretel Director is - 14.5.7805.0


      • #4
        Not sure exactly what you are trying to accomplish but the Shoretel handsets do not operate with SIP, they are MGCP.

        If you are trying to connect to a SIP trunking provider, you need to setup SIP trunks on the SG switch.

        If you are trying to support other handsets that use SIP, you need to setup SIP extension support.

        You are correct in that you need to disable UDP 5004 to enable SIP support on Shoretel. You must reboot all phones, switches and the Director server after doing so for the settings to take effect for RTP.


        • #5
          Here is my setup:

          Shoretel 530 Phone --> Shoregear switch--> Edgemarc Edge Router--> Voip Provider

          When the Call connects, the INVITE is received by the shoretel director and it responds back with a 200 OK which has the IP of the ShoreTel 530 phone....Once I answer the call on the Shortel phone it stream IP to the Edgmarc on port 5004 but it should send it to Port 12223 (which was received in the SIP INVITE to the ShoreGear switch).

          Make sense? I can send you a trace if that will help.
          I think there maybe something else I need to do forhe 530 config, but dont know what


          • #6
            I can trace on the Edemarc Router LAN side and I do not see any MGCP msgs between the PHone and the Shoregear switch either.


            • #7
              Sounds like it didn't take the UDP 5004 setting. Reboot the HQ, SG and phones again.

              Beyond that for sip troubleshooting, i'd suggest contacting your partner or Shoretel (if you have enterprise support) to engage in specific troubleshooting of your situation.

              An active support contract entitles you to support for this very thing.