Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Phones reboot into voice vlan - sort of...

    Hello, I'm having an issue where phones are not finding the voicemail server.


    First some background.
    My network is as follows.

    Vlan 1 (Data) = 10.0.0.0/23
    Data DHCP server is 10.0.1.203
    Default gateway is 10.0.1.220


    Vlan 2 (Voice) = 172.20.10.0/23
    Voice DHCP server & Voicemail server is 172.20.11.11
    Default gateway is 172.20.11.220


    When the system was installed, the installer installed a DHCP server on the voicemail server itself. The scope option 156 is on the vlan 1 data dhcp server. The phones boot to the data vlan, get the 156 scope option and reboot into the voice vlan. They get the 172 IP address and gain service. The phones work fine, no problems.

    The Shoretel best practices document indicate that the data vlan should host both DHCP scopes and I'd like to consolidate the DHCP servers for ease of maintenance.


    I've installed the voice scope on the data vlan DHCP server and applied the IP helper-address statement on the Procurve switch to allow IP address to be handed out to the voice vlan. I disable the DHCP scope on the voicemail server and enable it on the data DHCP server.

    I perform the CLEAR reset on the ip 560G phones and they reboot. They get the data vlan ip address and reboot. I can then see from the DHCP server address leases that the phone gets the voice vlan ip address (I can verify the MAC address that it's the correct phone) but the phone doesn't show that it has received the IP address on the screen and just continues the DHCP countdown.

    All the scope options on the original voicemail DHCP server are present on the voice DHCP scope on the data vlan DHCPO server so I can't figure out what's failing. I tried adding the 155 scope option, and even the 066 scope option, but they seem to make no difference.

    Any ideas what I'm doing wrong?

    Thanks for the help.

  • #2
    Sounds like a routing issue as a first guess. I'd try to configure a phone on the voice VLAN manually and then do some pings, etc to see if it can ping the DHCP server, gateway, etc. I'd also have a close look at your new voice scope and see if all the IP options are set properly: gateway, DNS, etc.

    You can also try mirroring the port the phone is connected to and watch the DHCP transactions in Wireshark or something. Also check the the 156 option in the voice scope has the VLAN info in it as well.

    Comment


    • #3
      Originally posted by Dingo View Post
      Hello, I'm having an issue where phones are not finding the voicemail server.


      First some background.
      My network is as follows.

      Vlan 1 (Data) = 10.0.0.0/23
      Data DHCP server is 10.0.1.203
      Default gateway is 10.0.1.220


      Vlan 2 (Voice) = 172.20.10.0/23
      Voice DHCP server & Voicemail server is 172.20.11.11
      Default gateway is 172.20.11.220


      When the system was installed, the installer installed a DHCP server on the voicemail server itself. The scope option 156 is on the vlan 1 data dhcp server. The phones boot to the data vlan, get the 156 scope option and reboot into the voice vlan. They get the 172 IP address and gain service. The phones work fine, no problems.

      The Shoretel best practices document indicate that the data vlan should host both DHCP scopes and I'd like to consolidate the DHCP servers for ease of maintenance.


      I've installed the voice scope on the data vlan DHCP server and applied the IP helper-address statement on the Procurve switch to allow IP address to be handed out to the voice vlan. I disable the DHCP scope on the voicemail server and enable it on the data DHCP server.

      I perform the CLEAR reset on the ip 560G phones and they reboot. They get the data vlan ip address and reboot. I can then see from the DHCP server address leases that the phone gets the voice vlan ip address (I can verify the MAC address that it's the correct phone) but the phone doesn't show that it has received the IP address on the screen and just continues the DHCP countdown.

      All the scope options on the original voicemail DHCP server are present on the voice DHCP scope on the data vlan DHCPO server so I can't figure out what's failing. I tried adding the 155 scope option, and even the 066 scope option, but they seem to make no difference.

      Any ideas what I'm doing wrong?

      Thanks for the help.

      From a switch standpoint, make sure that the DHCP server's port is Untagged on your Data VLAN, and NO for your Voice VLAN. Then make sure the ports for the phones are marked Untagged/Tagged respectively.

      Also, could you list exactly what you have for your DCHP option? it should be ftpservers=x.x.x.x,Layer2Tagging=1,VLANID=2

      Comment


      • #4
        What type of switches? Can you provide the running configuration for review?

        Comment


        • #5
          Originally posted by CT-Pros_Eric View Post
          From a switch standpoint, make sure that the DHCP server's port is Untagged on your Data VLAN, and NO for your Voice VLAN. Then make sure the ports for the phones are marked Untagged/Tagged respectively.

          Also, could you list exactly what you have for your DCHP option? it should be ftpservers=x.x.x.x,Layer2Tagging=1,VLANID=2
          I agree with Eric
          Your problem sounds like it might be because the DHCP server is on a switch port that is also a member of the voice vlan. As I recall, the DHCP server still records that it has given out a lease to a phone when you look in the Leases table, just that the phone never seems to get it.
          To conclude troubleshooting DHCP for the benefit of anybody doing this for the first time:
          * Make sure the DHCP server is connected to a port that is only a member of the data vlan.
          * Make sure that the device which is the default gateway on your voice vlan has some sort of IP Helper or Bootp/dhcp forwarding address so that it will forward DHCP messages to the appropriate server.
          * Check your DHCP server can ping the default gateway of the voice vlan.
          Last edited by ShoreTel_Dave; 08-24-2009, 04:05 AM.

          Comment


          • #6
            Originally posted by ShoreTel_Dave View Post
            I agree with Eric
            Your problem sounds like it might be because the DHCP server is on a switch port that is also a member of the voice vlan. As I recall, the DHCP server still records that it has given out a lease to a phone when you look in the Leases table, just that the phone never seems to get it.
            To conclude troubleshooting DHCP for the benefit of anybody doing this for the first time:
            * Make sure the DHCP server is connected to a port that is only a member of the data vlan.
            * Make sure that the device which is the default gateway on your voice vlan has some sort of IP Helper or Bootp/dhcp forwarding address so that it will forward DHCP messages to the appropriate server.
            * Check your DHCP server can ping the default gateway of the voice vlan.

            Back from vacation and I find that several of you hit the nail on the head. I guess I need to go and figure out WHY tagging the voice vlan to the DHCP server would cause a phone to get the lease but just hang, but my problem seems solved.

            Thanks for the help as this one had me stumped.

            Comment

            Working...
            X