Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • QoS questions

    Does any one have any advice (examples) for enabling QoS to work with ShoreTel phones?

    Thanks!

  • #2
    What switches do you have ? Vlans? WAN provider/type? MPLS? etc.. We need some more information.

    Comment


    • #3
      QoS questions

      We have cisco 3750's with separate vlans for voice, workstations, servers and management. We are using private 3 MB PPP P2P links between our two offices and the datacenter where the ShoreTel call manager and switches are. It would be helpful to have an example for the switches and the 2821 routers.

      Thanks.

      Comment


      • #4
        QOS Setup

        see if the attached document helps you any

        we have used it for our 2821's with great success.
        Attached Files

        Comment


        • #5
          QoS questions

          Thanks eazeaz. Could you possibly share your QoS configuration snippits on the routers and the switches? I'd greatly appreciate it.

          Comment


          • #6
            qos

            qos attached

            As the first document suggests, you need to make sure you set the DSCP properly in your shoretel director.

            the configs below are from 2821's, but should work in about any cisco router.
            Attached Files

            Comment


            • #7
              eazeaz; shouldn't your class-map statement read:
              class-map match-any SHORETEL_VOIP?
              since you want to match anything that matches your 2 access lists or DSCP EF; not ALL of them?
              that being said with 9.1 (if/when you have 9.1) i don't believe you'll need the access-group 102 statement since DSCP marking now extends to server. correct me if wrong. thanks

              Comment


              • #8
                Qos

                Good catch with the match any.

                We have seen posts where the DSCP marking does not work all the time. There are a few posts around here where it either magically stops working, or packets from certain devices are not really tagged. We put in access list 102 more as a safety net. I have never actually seen the behavior personally.

                Comment


                • #9
                  I have a couple of questions about the class map you created, specifically about the ACL's:

                  Code:
                  class-map match-all SHORETEL_VOIP
                   match ip dscp ef
                   match access-group 101
                   match access-group 102
                  
                  access-list 101 permit udp any any eq 2427
                  access-list 101 permit udp any any eq 2727
                  access-list 101 permit udp any any range 5440 5446
                  access-list 101 permit udp any any eq 5004
                  access-list 102 remark : ShoreTel Server VoIP Packets
                  access-list 102 permit udp any gt 1024 host 192.168.10.20 gt 1024
                  access-list 102 permit udp host 192.168.10.20 gt 1024 any gt 1024
                  I understand UDP Ports 2427, 2727, and 5440-5446. If you are using SIP, does ShoreTel still use 5004 at all? Also, access-list 102 confuses me. Would it not be just as efficient to just say:

                  Code:
                  access-list 102 permit udp any host 192.168.10.20
                  access-list 102 permit udp host 192.168.10.20 any
                  Logic behind that: When the server makes ANY outbound connection, whether for AD authentication, web browsing anywhere, ftp connection originated by the server, telnet connection to a switch, etc., the originating port will almost always be > 1024.

                  I don't understand the reasoning for udp>1024 to udp>1024 though.

                  Thanks.

                  Comment


                  • #10
                    If you match on a DSCP value, you don't need to match on the UDP range (which with SIP is random UDP ports... 5004 no longer applies).

                    From the Shoretel server perspective, you don't longer need to write an ACL to assign a TOS value for RTP streams leaving the Shoretel server with 9.0 or newer. Shoretel is now able to mark RTP streams from servers with the defined DSCP value.


                    Now that being said, depending on the architecture of your network, you may well want to mark other Shoretel traffic (signaling, PCM, etc.) with a different codepoint in one of the AF classes for your WAN.

                    Comment


                    • #11
                      I understand that 9.0+ marks the RTP streams DSCP EF, but I thought they did that with the signaling, too? What about the switches?

                      I see the earlier example is a good starting point for classifying and marking traffic. Would the example below be a good "catch-all" for phone, server, and switch traffic, regardless of whether or not you are using SIP?

                      Code:
                      interface Gig 0/0
                       service-policy output VOIP_POLICY
                      !
                      policy-map VOIP_POLICY
                       class SHORETEL_VOIP_RTP
                        priority percent 75
                       class SHORETEL_VOIP_RTP_NO_DSCP
                        set ip dscp ef
                        priority percent 75
                       class SHORETEL_CALL_CTRL
                        set ip dscp af31
                        priority percent 5
                       class class-default
                        set dscp default
                        fair-queue
                        random-detect
                      !
                      class-map match-any SHORETEL_VOIP_RTP
                       match ip dscp ef
                      !
                      class-map match-any SHORETEL_VOIP_NO_DSCP
                       match access-group 101
                      !
                      class-map match-any SHORETEL_CALL_CTRL
                       match access-group 102
                      !
                      access-list 101 permit udp any any eq 5004
                      !
                      access-list 102 permit udp any any eq 2427
                      access-list 102 permit udp any any eq 2727
                      access-list 102 permit udp any any range 5440 5446

                      Comment


                      • #12
                        No, signaling is not marked.

                        Your policy will accomplish prioritization of RTP streams and signaling traffic.

                        I don't know your exact network environment but keep in mind you should ALWAYS make sure your QOS design accomodates network control traffic. It should be of the highest priority and implemented as part of your policy design. This is even more critical in a WAN environment as you run routing protocols (OSPF, IS-IS, iBGP, etc).

                        Also, you are not prioritizing PCM traffic to the server. In a WAN scenario, it is common for congestion to cause Call Manager to slow down on the desktops and users to complain. You should consider this as part of your design for sites where they do not have a DVS.

                        Comment


                        • #13
                          Originally posted by cburgy View Post
                          No, signaling is not marked.

                          Your policy will accomplish prioritization of RTP streams and signaling traffic.

                          I don't know your exact network environment but keep in mind you should ALWAYS make sure your QOS design accomodates network control traffic. It should be of the highest priority and implemented as part of your policy design. This is even more critical in a WAN environment as you run routing protocols (OSPF, IS-IS, iBGP, etc).
                          I cannot find any documentation from Cisco explicitly stating whether or not they set DSCP automatically for the routing and link-layer protocols. I think they may, though, based on some of their documentation and descriptions. See this link for more info. I am making inquiries about that now. That raises a good point.

                          Everything I run is vlan-based, so I need to make sure it will work under "interface Vlan xx". I need to be able to implement this on Cisco Routers and Cisco 4500-series switches (that use MQC, not MLS). MLS has its own configurations and mappings.

                          Originally posted by cburgy View Post
                          Also, you are not prioritizing PCM traffic to the server. In a WAN scenario, it is common for congestion to cause Call Manager to slow down on the desktops and users to complain. You should consider this as part of your design for sites where they do not have a DVS.
                          Thanks for that. I'll go look that up this weekend. Also, how does the Contact Center software interact with all of this? Is it considered "call control" traffic, too?

                          Comment


                          • #14
                            In looking at the Ports used by PCM (see THIS thread), I can't see which ports, other than 5440, I should be worried about. We don't use soft phones. We don't have Distributed media servers.

                            Our "ShoreTel Network" consists of a ShoreWare Director server, a Contact Center server, multiple SG-40/60/120 switches, a few SG-1 (T1) switches) and that is it.

                            Which ports would be recommended to prioritize on the WAN for PCM?

                            Comment

                            Working...
                            X