Hi,
Please audit my Cisco 2960 POE switch config below. This will be installed just prior to a new ShoreTel install. Have I forgotten anything?
GigabitEthernet0/1 will be an uplink to the core router, and GigabitEthernet0/2 has a fiber module that connects to a little 8-port 3560 POE switch in an outbuilding.
I'm a little concerned that I don't know what to put in for programming of my uplink ports, if anything. Also, some configs that I've seen have "priority-queue out" on each switchport. Is that something that I should consider as well?
Thanks
sh config
Using 3028 out of 65536 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CAR_SWITCH1
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxx
!
username admin password 0 xxxxx
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/2
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/3
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/4
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/5
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/6
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/7
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/8
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/9
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/10
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/11
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/12
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/13
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/14
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/15
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/16
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/17
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/18
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/19
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/20
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/21
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/22
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/23
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/24
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet0/1
description Connected to CAR_ROUTER1 FastEthernet0/1
!
interface GigabitEthernet0/2
description Connected to CAR_SWITCH3 GigabitEthernet0/1 via FIBER
!
interface Vlan1
ip address 192.168.0.5 255.255.255.192
no ip route-cache
!
no ip http server
snmp-server community xxxxxxxxx RO
!
control-plane
!
!
line con 0
line vty 0 4
password xxxxx
login
length 0
line vty 5 15
password xxxxx
login
length 0
!
end
CAR_SWITCH1#
Please audit my Cisco 2960 POE switch config below. This will be installed just prior to a new ShoreTel install. Have I forgotten anything?
GigabitEthernet0/1 will be an uplink to the core router, and GigabitEthernet0/2 has a fiber module that connects to a little 8-port 3560 POE switch in an outbuilding.
I'm a little concerned that I don't know what to put in for programming of my uplink ports, if anything. Also, some configs that I've seen have "priority-queue out" on each switchport. Is that something that I should consider as well?
Thanks
sh config
Using 3028 out of 65536 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CAR_SWITCH1
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxx
!
username admin password 0 xxxxx
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/2
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/3
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/4
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/5
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/6
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/7
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/8
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/9
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/10
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/11
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/12
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/13
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/14
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/15
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/16
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/17
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/18
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/19
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/20
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/21
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/22
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/23
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface FastEthernet0/24
mls qos cos 5
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet0/1
description Connected to CAR_ROUTER1 FastEthernet0/1
!
interface GigabitEthernet0/2
description Connected to CAR_SWITCH3 GigabitEthernet0/1 via FIBER
!
interface Vlan1
ip address 192.168.0.5 255.255.255.192
no ip route-cache
!
no ip http server
snmp-server community xxxxxxxxx RO
!
control-plane
!
!
line con 0
line vty 0 4
password xxxxx
login
length 0
line vty 5 15
password xxxxx
login
length 0
!
end
CAR_SWITCH1#