Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NTP issues with phone terminals

    Hi All,

    I am a new member, 15 years IT & telecom experience. I do WAN & Cisco network support for one of my corporate clients who uses Shoretel VOIP for 7 of their sites - 6 are perfect, 1 is having issues with NTP and time on the phone units. The 6 that are working correctly are running DHCP/options on the server and the problem child is running DHCP/options and NTP from my WAN router (1841) - the installer refused to setup the server to provide these network functions. They have three 3560 switches, 2 VLANs (data and VOIP)- both work fine, and the switches have the correct NTP associations & status shows they are synched correctly, but the phones show incorrect time.

    I am not the installer, but I get to do the support as we supply the WAN and other corporate data support - the nearest Shoretel guy is 80 mins from the site.

    Any ideas on the problem with the phone terminal time?

    Thank you,

    Jerry Lee

  • #2
    The phones get their NTP server setting from an Option on DHCP.
    This is Option 3 off the top of my head, but a glance at an MS DHCP server will confirm it.

    You can ascertain whether or not this is configured on the phone by Dialling :
    MUTE + I N F O #
    # through all the settings on the screen until you see the time server.
    If it is set then confirm that the IP address is the correct source. If not, then look to try configuring option 3 on the phone.
    Reboot the phones after changing DHCO options.

    Comment


    • #3
      Dave,

      Thanks for the info - I am traveling to the site on Sunday - they are tired of messing around with this and want me there to fix it.

      Do you have a good link to an Admin Manual or a PDF that I can download and dig through while I am parked in the airport?

      Thanks,

      Jerry Lee

      Comment


      • #4
        DHCP Option 42 is NTP

        Here's how our Cisco 3560 switches are configured for the Voice VLAN. We point the phones to an internet NTP Server.

        ip dhcp pool VoiceVLAN
        network 10.10.58.0 255.255.254.0
        option 156 ascii "ftpservers=10.10.60.63,layer2tagging=1,vlanid =20"
        domain-name xyz.com
        dns-server 10.10.60.54 10.10.9.10
        default-router 10.10.58.1
        option 42 ip 192.43.244.18
        lease 7

        Gary

        Comment


        • #5
          The DHCP server should have option 4 added for time.

          Comment


          • #6
            Originally posted by southeasternMI View Post
            The DHCP server should have option 4 added for time.
            I knew it was down there somewhere.:whistling:

            Comment


            • #7
              Phone Time Issue

              I was having this same issue with the incorrect time on the phones. I had the server support tech, add the SNTP ip address on the DHCP server. Whichever server provides time to the who network that is what we used and it works. It will require a reboot of the phone to get the correct time to display. Also you mention VLANS These are also programmed in the DHCP server. So when I install new phone there is no programming to be done, because the DCHP will push the program assignement to the phones. I am not a server or some Ghurue but it works all the time. Make sure option 156 is assigned also.

              Comment


              • #8
                Originally posted by ShoreTel_Dave View Post
                I knew it was down there somewhere.:whistling:
                Option 4 and 42 both work but I think 42 is newer and should be the preffered option for NTP.

                Comment


                • #9
                  I am having a similar issue, except my phones are pulling the correct ntp address but not showing the correct time. I have option 42 set on the dhcp server with our ntp address. The phone pulls this ntp address, but the time is incorrect. I have used the mute clear# option on the phones so they would do a complete reset of the settings, but still have the same problem. Anyone else have this problem?

                  Comment


                  • #10
                    Originally posted by sisaacso1 View Post
                    I am having a similar issue, except my phones are pulling the correct ntp address but not showing the correct time. I have option 42 set on the dhcp server with our ntp address. The phone pulls this ntp address, but the time is incorrect. I have used the mute clear# option on the phones so they would do a complete reset of the settings, but still have the same problem. Anyone else have this problem?
                    How wrong is the time? Are all the phones showing the same time or are they showing random times?

                    If they are all showing the same time it could be a timezone problem.

                    Comment

                    Working...
                    X