Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newbie, setup help

    I work for a cisco house and have convinced my company that shoretel is the way forward based on feature set and cost. but I need to prove this.

    so I was hoping for a little help to get my system up and running

    I have a shoregear 220E1
    4 phones
    windows 2003 server

    so far I have installed the switch (10.11.40.3)
    Plugged the phones in
    installed director on my server (10.11.40.5)
    added the switch to the director


    I am using a cisco switch for POE and DHCP see config below

    ip dhcp pool vlan40
    network 10.11.40.0 255.255.248.0
    default-router 10.11.40.254
    option 156 ascii "ftpservers=10.11.40.5, country=1, language=1, layer2tagging
    =40,vlanid=40"

    switchport config for phones and server

    interface FastEthernet0/21
    switchport access vlan 40
    end

    First Issue

    The phone gets an ip address but doesn't seem to get the FTP address
    and currently say "no service" - this is my first issue


    Any help to get started would be great

    thanks in advanced

  • #2
    In the switch did you set up port for ip phones? From director click on the switch and make sure that you have at least 1 port checked for IP Phone, this will allow 5 ip phones to register with the switch.

    Comment


    • #3
      If your passing DHCP out from you server 03 box, you string should look like this.

      ftpservers=10.11.40.5, Layer2Tagging=40, VlanId=40

      don't need the ascii or languages

      Comment


      • #4
        You are most of the way there...
        Your DHCP option is wrong.. The Layer2Tagging=40 should actually be Layer2Tagging=1 This is simply a binary switch 1=on 0=off, so 40 is an invalid flag. The VlanId=40 is ok.
        And, like kjavernick said, make sure you have enabled IP phones on that switch..

        Good luck!

        Comment


        • #5
          excellent. just had to change the dhcp string and worked fine. Didn't have to enable a port for 5 phones. I think the switch should support 70 phone + 150 if you convert the digital trunks

          thanks

          again

          Comment


          • #6
            Is this working now? It seems weird that you set "layer2tagging=1,vlanid=40" and put the cisco switchport in access mode on vlan 40. You have put the phone in trunk mode and the switch in access mode.

            Are you plugging PCs in to the second port on the phone? Are they on vlan 40 also? If the PCs should be on a different vlan, then you would need the switchport in trunk mode. Something like:

            interface FastEthernet0/21
            switchport trunk encapsulation dot1q
            switchport mode trunk
            switchport trunk native-vlan-id 10
            end

            That should put the phones on vlan 40 and PCs on vlan 10.
            Last edited by aclements; 01-16-2009, 05:02 PM.

            Comment


            • #7
              You'll also want to be sure you set the DSCP value in Director to 184 (under call control -> options) and configure your Cisco switches to trust the DSCP bit on the port and prioritize accordingly.

              Make sure your ip phone address map is setup properly.

              You'll want to modify the default codecs (the new default codec list doesn't sound right to most people).

              We recommend a custom intra-site codec list with the following codecs in order (thanks to Tom Porter for all the testing on this):

              L16/8000
              G722/8000
              PCMU/8000

              Make sure your voicemail notification group has trunk to trunk transfer rights.

              Comment

              Working...
              X