Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco (3750) config options (& QoS) ... Help!

    Hi All,

    We're due to start installing ShoreTel kit next week onto our Cisco network. I'm trying to swap up on what config to use for a port on our 3750's (we use 3750's for everything, access switches, and as a core router stack)... the recommended config for phones (shared with a PC) seems to be this:

    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 16

    to put the PC into vlan 16, and the phone would read from DHCP which vlan (vlan 11 in our case) it should go into and reboot to that vlan.

    That sounds fine.. but people also seem to be using the following style of config (which has previously worked for me on Avaya kit):

    switchport access vlan 16
    switchport mode access
    switchport voice vlan 11

    Does anyone know if that second example works fine with ShoreTel phones? I (and I don't know why) would tend to prefer not to trunk everything, so the second option seems more appealing.

    Opinions please?

    Also... while I have your attention... help with QoS would be great as I've never done it before.

    I've enabled "mls qos" on the switches globally... and per port people seem to be suggesting a setup like this:

    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    mls qos trust cos
    auto qos voip trust

    Is that all I need to do per port etc? From what I can work out, the last line there should make the switches setup the CoS-to-DSCP map settings (whatever they are) automatically without me having to do anything else?

    Many thanks for your help and fast responce.

    Kind Regards,

    Steve
    Last edited by steveprentice; 06-27-2008, 08:28 AM.

  • #2
    Just enable

    "auto qos voip trust" on every port then
    " mls qos trust dscp" on every port.

    last but not least if you are using less bandwidth on your uplink port like a wireless bridge make sure you set

    "srr-queue bandwidth limit 10"

    Where 10 is a percentage of the interface speed can be 10-90 I believe. I used 10 to represent a connection over a wireless bridge with a 10 Meg pipe.
    Sergio Valles
    [email protected]
    # 909-972-0398 Direct
    Certified ShoreTel Engineer
    http://www.intelesysone.com

    Comment


    • #3
      Here's a stupid question: Do you need to enable QOS on all switches, or just the L3 switch?

      We've got a slew of Linksys 224P's all connected to a Cisco 3750 running QOS, but I still get a lot of "Excessive number of packets lost..."

      I'm checking on the QOS on all of the L3 switches across the WAN.

      Comment


      • #4
        Hi Steve,

        I had initally tried the second configuration at our site such as

        switchport access vlan X (data network)
        switchport mode access
        switchport voice vlan y (voice network)

        but this configuration did not seem to work. It turns out that the "switchport voice vlan" command uses proprietary communication for Cisco equipment where the end device is also a Cisco device.

        The switch will send out Cisco Discovery Protocol messages (CDP) to the end devcie (ie a Cisco Phone), the phone will reply and make use of the issued "switchport voice vlan" command.

        Since the Shoretel phone is not a Cisco device, it will not understand the CDP messages and will not reply back to the switch.

        Perhaps there is a work around. Until then, using the following series of commands is still your best bet:

        switchport mode trunk
        switchport trunk encapsulation dot1q
        switchport trunk native vlan X

        I would also apply the following commnad to the end of that staement:

        switchport trunk allowed vlan x,y

        This way, the port will only listen to broadcast tracffic for only your data vlan x and you voice vlan y, else the port will listen to all broadcast traffic for every vlan since it is a trunk and seriously cripple your voice quality.

        Hope this helped.

        Regards,

        Comment


        • #5
          Hello all,

          Very interesting topic... You're welcome to call me stupid but some of the information posted regarding Cisco Auto QoS is very incorrect and it would be very annoying to find people speading bad information into the public arena.

          I've been fortunate enough to earn my Cisco Cert Voice Professional as well as my Shoretel Cert Engineer... BTW, guess which one I think is more valuable.

          Anyway, Cisco Auto QoS relies on CDP (Cisco Discovery Protocol) and is designed with Cisco phones in mind. Auto QoS will do nothing for Shoretel phones on the LAN.

          Additionally, DSCP values are a layer 3 functionality and will not provide any specialized queuing within the switch.

          The Shoretel QoS technote is pretty good for the lay person to configure QoS over the WAN.

          I would also encourage engineers and consultants to not provide incorrect information to their clients. It will affect your credibility.

          Comment


          • #6
            Let me clear the air here Brian what you said about Cisco Auto qos not affecting the phones is incorrect.

            1. Anyway, Cisco Auto QoS relies on CDP (Cisco Discovery Protocol) and is designed with Cisco phones in mind. Auto QoS will do nothing for Shoretel phones on the LAN.

            Correction - Cisco Auto QoS only needs CDP if if you run "Auto qos voip cisco-phone". In my answer I stated "Auto qos voip trust" which uses th incoming DSCP code point the ShoreTel phone hands off.

            As for Qos not having an impact on the lan you are also mistaken example lets say I have a access switch 3560G 48 Ports and am running 565G phones in front of the PC. Lets assume I am using lacp and I have 2 1Gig links to my distribution switch I can potentially oversubscribe that link at a ratio of 24 to 1 what happens if multiple people are sending big files to a server hanging off the distribution switch or Core switch? This is where Qos on a switch is very valuable this is the same as having 100 FastEthernet link to your router with only a T-1 on the other side what happens to all those packets that have to go out a 1.544 link but my link is already maxed out they get queued right...


            2. Additionally, DSCP values are a layer 3 functionality and will not provide any specialized queuing within the switch.

            Correction - DSCP values from a trusted port are valuable for end to end qos. As for your queuing question read my answer above you could have an issue if you are traveling between layer 2 and 3 switches but thats why auto qos creates DSCP to COS map. I would also encourage you to study your Cisco ONT literature. Packets will containing both DSCP and COS at the same time its not one or the other.

            3. I would also encourage engineers and consultants to not provide incorrect information to their clients. It will affect your credibility.

            Correction - I want to tell you to follow your own advise. Stating to be Cisco Cert Voice Professional with this bad information you must install Cisco systems and what to give bad information to ShoreTel installers.

            FYI I am also CCNP certified and a ShoreTel Engineer.

            Please do your research before insulting people thanks.
            Last edited by svalles; 10-03-2008, 01:19 AM.
            Sergio Valles
            [email protected]
            # 909-972-0398 Direct
            Certified ShoreTel Engineer
            http://www.intelesysone.com

            Comment


            • #7
              I know this is a late reply, but from what I am reading autoqos does require CDP. This is from Cisco:

              . Minimum requirements to enable Cisco AutoQoS for VoIP traffic on supported platforms for WAN interfaces:
              Configure an IP address on the interface or a sub-interface.

              Configure "bandwidth" under any participating interfaces or sub-interfaces. For ATM PVC, configure "vbr-nrt" under the PVC.

              Minimum requirements to enable Cisco AutoQoS for VoIP traffic on supported LAN interfaces for switch platforms:

              CDP must be enabled

              PFC or PFC2 is required for "trust dscp" and "ciscosoftphone" keywords on the Cisco Catalyst 6500 switch

              The Enhanced Image (EI) is required on the Cisco Catalyst 2950 Series Switches



              Not sure if anyone has any input, but I'd like to know myself.

              Comment


              • #8
                Sergio Valles you are the MAN! thanks for clearing that up!

                Comment

                Working...
                X