Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting Up Option 156 For ShoreTel Phones

    All though most people may know how to set this up I wanted to post this for those that may not know how. Option 156 is a DHCP option that is responsible for handing out critical information to phones thru DHCP. This DHCP option is not built into windows within the predefined options and therefore must be created and configured for your use.


    The below information will apply to you if you have a windows server with an active DHCP role


    To set up DHCP option 156 for ShoreTel telephones:
    • Step 1 Open DHCP Manager on your Microsoft DHCP server.
    • Step 2 Right-click the DHCP server, and select Set pre-defined options.
    NOTE If your organization is separated into separate subnets, make sure to select the proper subnet. For example, if you have a global organization and would like to configure the DHCP server to deliver the Spanish tones and cadences only to theIP phones in your office in Spain, you should make sure to select that particular subnet of users. If you do not specify the subnet, then all phones that boot from this DHCP server will receive Spanish tones and cadences.
    • Step 3 Click Add.
    • Step 4 Set Name to IP Phone Boot Server.
    • Step 5 Set Data Type to String.
    • Step 6 Set Code to 156 and add a description, if desired.
    • Step 7 Navigate to the scope options and add option 156.
    • Step 8 Set the value of option 156 to: ftpservers=ip_address, country=n, language=n, layer2tagging=n, vlanid=n

    Here is an example if you server ip was 192.168.1.50

    ftpservers=192.168.1.50, country=n, language=n, layer2tagging=n, vlanid=n




    The most basic value needed for Option 156:

    ShoreTel Onsite: ftpservers=192.168.1.50
    Shoretel Sky/Cloud: configservers=192.168.1.50
    Last edited by Lance; 02-14-2018, 06:25 PM.
    Lance Paddock
    BTX | Business Telephone eXchange
    1(800) 289-0299

  • #2
    Options can be configured on multiple types of a devices and this process is not limited to a windows server.

    Here is an example of a Cisco configuration


    How to setup DHCP on a Cisco switch instead of a Microsoft DHCP server

    (example config for DHCP and for a switchport )
    ip dhcp pool VOICE
    network 192.168.4.0 255.255.255.0
    domain-name corp.xxxonline.com
    dns-server 192.168.0.30 192.168.0.31
    default-router 192.168.4.254
    option 156 ascii "ftpservers=172.16.4.20,layer2tagging=1,vlanid =4"
    ip dhcp pool DATA
    network 192.168.0.0 255.255.255.0
    domain-name corp.xxxonline.com
    dns-server 192.168.0.30 192.168.0.31
    default-router 192.168.0.254
    option 156 ascii "ftpservers=172.16.4.20,layer2tagging=1,vlanid =4"

    !
    interface GigabitEthernet1/0/14
    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 1
    duplex full
    spanning-tree portfast
    end
    Last edited by Lance; 02-09-2018, 12:15 PM.
    Lance Paddock
    BTX | Business Telephone eXchange
    1(800) 289-0299

    Comment


    • #3
      Good stuff from Lance, as usual. Thanks for this info, I am sure many people will use this!

      Comment


      • #4
        Setting Up DHCP options in a Sonicwall Version 5.6+

        1.DHCP Server must be enabled (obviously). Click 'Advanced' tab next to Enable DHCP Server
        2. Create two Objects
        2a. Shoretel Object (name is irrelevant)
        2b. Option 156
        2c. Option Type String
        2d. Option Value: FtpServers=<serverip>, country=<countrycode>, language=<languagecode>, layer2tagging=<0 or 1, 0 is disabled>, vlanid=<yourvlanid>

        example: FtpServers=192.168.1.5, country=1, language=1, layer2tagging=0, vlanid=0

        2e. Click OK
        2f. NTP Object (name is irrelevant)
        2g. Option 4
        2h. Option Value: <yourntpipaddress>
        2i. Click OK

        3. Next Tab, Option Groups
        4. Create a Shoretel_Group, add both objects you've just created
        5. Click on 'Configure' next to your DHCP range
        6. Click the 'Advanced' tab
        7. Under DHCP Generic Options, Choose your 'Shoretel_group', and click OK.

        Completed.

        Had to do this yesterday and wanted to make sure people could find how to do it.
        Lance Paddock
        BTX | Business Telephone eXchange
        1(800) 289-0299

        Comment

        Working...
        X