Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DHCP Scoop

    What's the scope on migrating to DHCP for phones so they boot right out of the box without programming even a vlan-id?

    How can a DHCP server ID them as phones, and send them the right stuff?

  • #2
    Originally posted by TomLine
    What's the scope on migrating to DHCP for phones so they boot right out of the box without programming even a vlan-id?

    How can a DHCP server ID them as phones, and send them the right stuff?
    For an IP100, it is option 155 and for a IP210/IP230/IP212K/IP560 it is DHCP option 156.

    Option 156 Values is:
    ftpservers=ip_address, country=n, language=n, layer2tagging=n, vlanid=n

    Country will probably be 1 (USA) and language will be 1 (English). You can use 0 for Vlanid and Layer2tagging if you are not using it.

    All the variables can be found in Chapter 9 of the Planning and Installation guide.

    Comment


    • #3
      Originally posted by Charles
      For an IP100, it is option 155 and for a IP210/IP230/IP212K/IP560 it is DHCP option 156.

      Option 156 Values is:
      ftpservers=ip_address, country=n, language=n, layer2tagging=n, vlanid=n

      Country will probably be 1 (USA) and language will be 1 (English). You can use 0 for Vlanid and Layer2tagging if you are not using it.

      All the variables can be found in Chapter 9 of the Planning and Installation guide.

      To expand on what Charles has stated.

      If you choose to set you Vlan tagging out using dhcp you need to plan it right.

      Lets say you are turning vlan tagging on and and setting the phone to Vlan 2 and your default vlan is vlan 1.

      You plug your new phone into your lan and it grabs an address for the data vlan. Because of the settings in option 156 the phone requests an address on vlan 2.

      You need to make sure your data dhcp pool is large enough to handle all the phones and your PC. The dhcp server is going to hold on to the address handed out when the phone first booted until the lease time is up.

      If you have 150 phones and 150 on the same LAN you are going to run out of addresses on your dhcp server if you are running a 24 bit mask.
      There are 10 types of people in the world, those that understand binary and those that donít.

      Comment


      • #4
        "Lets say you are turning vlan tagging on and and setting the phone to Vlan 2 and your default vlan is vlan 1.

        You plug your new phone into your lan and it grabs an address for the data vlan. Because of the settings in option 156 the phone requests an address on vlan 2."

        Can you elaborate a bit on this? How does the phones know to pick up Vlan 2 and use a certain SNTP and computers know to pick up Vlan 1 and no SNTP?

        is it because the phones are looking for Option 156 and compters don't?

        Comment


        • #5
          Originally posted by Flipmstr2
          is it because the phones are looking for Option 156 and compters don't?
          Yes, the VLAN ID 2 is assigned in the DHCP option 156 and the PC does not read this option so it stays in the default VLAN.

          Comment


          • #6
            Just to add something ShoreTel phones will send a lease release before they reboot and move over to the other vlan.
            Sergio Valles
            [email protected]
            # 909-972-0398 Direct
            Certified ShoreTel Engineer
            http://www.intelesysone.com

            Comment


            • #7
              If you set tagging and VLan ID locally on the phone (adds about 30 seconds to setup of each phone) it won't hit your data vlan first. It is good to still have that option 156 in there in case one of the phones looses these settings it would still boot up, just through the data vlan.

              BUT, make sure you are using a default vlan for your data......I have a TAC case open right now because one of our sites has our data vlan as vlan 2 and the trunking won't work properly to get the pc a vlan 2 ip and the phone to get a voice vlan ID.

              Comment


              • #8
                tnshurtm


                I am little lost. Your default vlanID can be anything you want it to be. The default for all vendors I have worked with is vlan 1. You should be able to change it with out issue.
                Last edited by aspen; 02-22-2007, 01:10 PM.
                There are 10 types of people in the world, those that understand binary and those that donít.

                Comment


                • #9
                  Originally posted by aspen
                  tnshurtm


                  I am little lost. Your default vlanID can be anything you want it to be. The default for all vendors I have worked with is vlan 1. You should be able to change it with out issue.

                  My problem is that the default Vlan for Cisco is Vlan 1, and I want my data to be Vlan 2, voice to be Vlan 5. I can't get the ports on my Cisco switch to default fo Vlan 2. I can set the port to "access", but that disables trunking and you can't use the phone on that port.

                  I have another thread dealing with this. I have a TAC case open w/ Cisco and they are still working on it. No one on the couple forum sites that I have been on can come up with a solution. Maybe you could help.

                  Here is the other threads:

                  http://www.shoretelforums.com/forums...hread.php?t=88

                  http://www.petri.co.il/forums/showthread.php?t=13613

                  Marc

                  Comment


                  • #10
                    Your config should look like this.

                    You need the "switchport trunk native vlan 2" This will place any untagged packets received on VLAN 2. Without this cmd the default native VLAN is used (VLAN ID=1)

                    VLAN 1 will still be on the switch put not in use. This is taken from a ST doc on Vlans and changed around a bit. PM me you email address and I will send you the ST doc. Let me know if that helps any.

                    Tom

                    !
                    interface FastEthernet0/1
                    description : Link to PC on QA VLAN + ShoreTel IP Phone
                    switchport mode trunk
                    ! Allows the port to receive tagged and untagged packets
                    switchport trunk encapsulation dot1q
                    ! Sets the tagging mode to the IEEE 802.1Q specification
                    switchport trunk native vlan 2
                    ! Any untagged packets received will be placed in this VLAN
                    ! Without this cmd the default native VLAN is used (VLAN ID=1)
                    !
                    interface FastEthernet0/2
                    description : Link to Stand-Alone ShoreTel IP Phone (VLAN 5, tagged)
                    switchport mode trunk
                    switchport trunk encapsulation dot1q
                    switchport trunk native vlan 5
                    !
                    interface FastEthernet0/3
                    description : Link to Stand-Alone PC on Data VLAN (VLAN 2, untagged)
                    switchport mode access ! (this is the default and will not display)
                    switchport access vlan 2
                    .
                    .
                    .
                    .
                    .

                    interface VLAN2
                    description : Data VLAN/Network
                    ip address 1.1.1.1 255.255.255.0
                    !
                    !
                    !
                    interface VLAN5
                    description : Voice VLAN/Network
                    ip address 3.3.3.1 255.255.255.0
                    ip helper-address 1.1.1.5
                    !
                    There are 10 types of people in the world, those that understand binary and those that donít.

                    Comment


                    • #11
                      Thanks Tom,

                      I have that document and have tried that config. Here is how I have tried the configurations. I am currently on hold with a "tech" at Cisco while he consults the real tech.

                      If the port is set up like this, the PC gets a vlan2 ip and phone doesn't work at all:

                      interface FastEthernet0/24
                      switchport access vlan 2
                      switchport voice vlan 5
                      spanning-tree portfast


                      If it is set up like this, the PC gets a Vlan1 ip and the phone works:

                      interface FastEthernet0/25
                      switchport voice vlan 5
                      spanning-tree portfast


                      If I set it up like this, I get the same results as above:

                      interface FastEthernet0/25
                      switchport trunk native vlan 2
                      switchport voice vlan 5
                      spanning-tree portfast


                      If I set it up like this, (which is in the shoretel doc that Aaron Z sent (attached)), the PC gets a vlan 2 ip address and the phone does not work:

                      switchport mode trunk

                      switchport trunk encapsulation dot1q

                      switchport trunk native vlan 2

                      Comment


                      • #12
                        Any way you work to get the phone and the pc to work the port has to be in trunk mode.

                        What happens when you use this config and give the phone a static address with an address and tagging on vlan 5? Does it move traffic?

                        switchport mode trunk
                        switchport trunk encapsulation dot1q
                        switchport trunk native vlan 2
                        There are 10 types of people in the world, those that understand binary and those that donít.

                        Comment


                        • #13
                          Originally posted by aspen
                          Any way you work to get the phone and the pc to work the port has to be in trunk mode.

                          What happens when you use this config and give the phone a static address with an address and tagging on vlan 5? Does it move traffic?

                          switchport mode trunk
                          switchport trunk encapsulation dot1q
                          switchport trunk native vlan 2

                          With this configuration, When I boot the phone, it goes out to the VLAN 2 DHCP server and gathers info from the 156 line, reconfigures and when it tries to get to the FTP server, it fails.....and ends up at "no service"

                          If I try to manually set the IP, Tagging, and VLAN, It phone finds the VLAN 5 DHCP Server, is able to contact the FTP server, downloads files, and works

                          The problem I am guessing is getting DHCP to work for VLAN on that port?????

                          Comment


                          • #14
                            Where are you running dhcp. Are you helpering dhcp from vlan 5 or running in on a switch or router connected to vlan 5?
                            There are 10 types of people in the world, those that understand binary and those that donít.

                            Comment


                            • #15
                              The Vlan5 dhcp server is on Vlan1. The Vlan2 dhcp is on vlan2. I have a helper statement on my core router for Vlan5. Everything on Vlan1 has no problem getting a Vlan5 address.

                              Comment

                              Working...
                              X