No announcement yet.
  • Filter
  • Time
  • Show
Clear All
new posts

  • 480g will not update firmware

    Recently did an update of director to 22.23.5600 everything went very well . I also took the time to audit our broken phone pile.

    I have one 480g that has been unable to upgrade firmware for quite some time (years at this point) and decided to try and figure it out.

    At this point it is more about the challenge than actual need for the phone but was wondering if anyone has any input into why it is failing.

    From director I tried endlessly pushing the firmware to the phone, even a previous build and it will download and stage but never install.

    I decided to SSH and use the update-stage and update-do commands to see if i could get any additonal output and it seems that it is complaining about being a read-only file system when it tries to remove the old firmware (staged) with the new. Attached is that log with IP's scrubbed.

    I have tried using chmod to modify permissions on the folder in question along with trying rename and even delete the folder it is complaining about and get the same result as the error messages in the log.

    If anyone has any suggestions it would be greatly appreciated.

    **EDIT** I have run the clear cmd multiple times and also from an ssh session
    Attached Files