Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mitel Connect Softphone not routing over VPN sometimes

    We've always had this problem going back to 14.2, but in the old Shoretel Communicator we could select a network adapter under the Softphone settings and force traffic to use the VPN tunnel. With the new Mitel Connect there are no network adapter settings for the Softphone. We can see connection attempts to our internal HQ server trying to route out a user's default gateway instead of over the VPN tunnel. Is there any way to select the correct VPN adapter in Mitel Connect? Even if it is a registry setting or something?

  • #2
    Don't think this is a connect client issue. More likely to be a route issue within your vpn software.

    Comment


    • #3
      Correct. The client will need access to all phone appliances and phone networks, should be added to the VPN scope/range. Mitel Connect uses the FQDN assigned to servers so you should also check and make sure they are resolvable. If a VPN is not needed for other applications/access, you can deploy an Edge Gateway to facilitate a VPN-less Connect Client access with softphone capability.

      Comment


      • #4
        It is not a route issue with the VPN software. The scopes are correctly defined. Pings and traceroutes traverse the correct routes, but we can nevertheless see Connect Client traffic attempting to route over the user's default gateway. It is a random issue that doesn't even impact the same user consistently. It probably is a compatibility issue with our Palo-Alto VPN client if this is not behavior that is widely known about already.

        Comment


        • #5
          Make sure you're on a supported build, collect your pcals and client logs and open a ticket with Mitel.

          May be candidate selection in the client doing something funky.

          Client logs will tell you what adapter it's choosing.

          Comment


          • #6
            We had a very similar issue - no support from mitel as we were not using their vpn concentrator.

            best resolution we could find in the short term was disable any IPv6 protocols in operation (any adapters) especially on the vpn side. this seemed to cure most of the issues although no-one really knows why.

            Just one of the very many reasons we are getting rid of connect for a better solution.

            Comment


            • #7
              For the ipv6 adapter thing. There was a big in the connect client that would select the ipv6 adapters to use for audio. Latest client should fix that specific problem

              Comment


              • #8
                I've had luck with changing the route metric for the adapter. If you open a command prompt and type 'route print', you can see the route metric. The lowest metric gets the highest priority. To change the metric for your VPN adapter, go to the IPv4 settings for the adapter, open the advanced properties (below DNS), deselect the automatic setting and put in a number that is lower than the current lowest.

                Comment


                • #9
                  Thanks for the replies everybody, I will try these suggestions!

                  Comment

                  Working...
                  X