Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mitel Connect - Robotic Voice Issues - Please Help

    Greetings,

    We are having softphone call quality issues (Desk Phones work perfectly fine). Every so often a user makes/receives a call (doesn't matter which) and when the user talks they sound like a robot, but can hear the other person perfectly fine.

    Note- When they hangup and call back it always is 100% clear

    Mitel Server Build:22.11.4900.0 Enterprise Edition
    MItel Connect Version: 214.100.1222.0

    Hardware Info
    Desktop: Lenovo Think Center M715Q
    Laptop: Lenovo MT Thinkpad E595
    *Both have 8 GB of RAM

    Who is impacted: specific people, but these people are using the same hardware as others who are working fine

    What we have tried/noticed:
    1) Headsets - We have tried different headsets and the integrated sound card on a laptop. It seems to be computer specific as we use the same headsets on other pc's/laptops and they work fine.
    2) Maxing out Resources on PC/Laptop - We have tried maxing out resources on a Laptop we know is good and can't replicate the issue. Also when individuals are having the issue they can just use Mitel and have the issue.
    3) Network - We have checked our network already with our 3rd party Vendor (that works with Mitel) and followed all of Mitel's recommendations but do not think it is a network issue because other machines at the same site work perfectly fine. Mitel believes it is localized to the individual device
    4) Windows Firewall - We have "C:\Program Files (x86)\Mitel\Connect\Mitel.exe" added in windows firewall.
    5) GPO/Domain - We have two separate scenarios where a user logs into one PC and has issues but when they log into a laptop it works fine (there are laptops that don't work). Because of this it can't be a GPO/Domain issue
    6) OS/Build - The machines are on 1909 (OS Build 18363.720)
    7) Windows Update - Updates are managed by WSUS and should be the same throughout the organization. Because some are/aren't working we don't believe it to be an update issue. We have verified they are using the same version/build.
    8) AV - All PC's have Vipre and Cryptoprevent on them. We tried uninstalling both on multiple machines and they still have the issue.
    9) Drivers - We verified PCs/Laptops have the same drivers Sound Card Drivers
    10) We used wireshark to capture packets to listen to the audio and going into the sound card is playing clear
    11) VOIP - This is like comparing apples to oranges, but we used the 8x8 voip software to test and works just fine (No call issues)
    12) There are no other common applications except Mitel Connect
    13) We have upgraded Mitel Connect and our Server Build Multiple times hoping it would fix this issue
    14) Under sound settings we disabled all other Microphones. We also compared settings to machines that are working and they are the same
    15) Doesn't matter if the call is internal or external


    *If you solve this you will be a hero as we have spent weeks trying to fix this
    Last edited by ShoreTel_Michael; 05-15-2020, 07:23 AM.

  • #2
    What codec are you using?

    Comment


    • #3
      Codec Bandwidth Sampling Rate Max Audio
      Streams
      Max SRTP
      Streams
      G711 (both a-law
      and -law)
      64 kbps 8 kHz 50 50

      Comment


      • #4
        We've experienced poor calls on our softphones in the office. The softphone seems to require plenty of resources of the office PCs.
        Never had the same issue on my laptop with the following:
        Processor Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz, 2401 Mhz, 2 Core(s), 4 Logical Processor(s)
        Installed Physical Memory (RAM) 16.0 GB

        Unfortunately, I don't have access to an office PC to compare the specs. The manager in the office implied the client was a resource pig.

        Comment


        • #5
          We ran Prime 95 on it to max out resources, used softphone for a week, and couldn't replicate it. I don't think it is a resource issue

          Comment


          • #6
            For those of you having this issue, It is 100% an issue with Mitel. Here is an email I sent out to someone else having this same issue. If this helps you please reply to this post letting me know. I'm curious how many people this is impacting.


            Message
            This probably took us 5 months of isolating and testing (we even bought the brand of headset that they "Support). We literally caught packets from every signal point in our environment and narrowed it down to the software itself.

            Mitel said that had 1 client before us having issues similar and they gave us an experimental version of Mitel (Version 214.100.1231.0). This version is really glitchy. You have to uninstall presenter/connect, reboot, then in stall the software. I believe midway through September they are releasing a version that is supposed to *fix* this issue.

            I'd demand the experimental version from them, add it to one or two machines to see if it fixes the issue, then assuming it does add it to the other machines that are having issues.


            Edit (It really probably took 8 months to fix this)

            Comment

            Working...
            X