Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • User Voicemail Skipping

    Salutations,

    Brand new user here. I am having an interesting issue with our Voicemail, and after extensive google searching I have been unable to find anyone having similar. Google did lead me to these forums though so I hope to lean on you fine folks from time to time!

    Bit of background, I have inherited an aging Shoretel system with about 50 IP phones of various G and non G models running a Shoregear T1 and an SG-90. I have very little PBX experience and if I am honest, insufficient networking knowledge for what I have been placed in charge of. Recently in an attempt to increase throughput in the office for lower cost I tested a Grandstream GXP2140 on the system using SIP protocols. I had hoped to replace our IP115 and 230's with a cheap G phone. After getting it working for my test user, I realized we had no SIP licenses and I abandoned the project as economically inefficient. Since then we have been having a strange issue where randomly some users experience problems with their voicemail menu skipping ahead. It will begin listing off the options such as "press 1 to hear message, press 2 to ...", but after the attendant says 2 or 3 words she skips to the next option. "Welcome to Shor..., Press 1 to..., Press 2 to..., Press 3..., Press 4..." Users are unable to access voicemail since it does not accept any input while this is happening. After anywhere from 5 minutes to 20 minutes the issue will cease and the user will be able to get their voicemail. Users appear to be randomly affected and this does not affect their ability to place or receive calls or transfers.

    I have rebooted the appliances and our resource usage is under 20%. No errors in the logs to indicate an issue. I have gone back an reversed the SIP settings I changed (that I could remember) in case something I did was the cause, but it did not resolve.

    Does anyone have any thoughts on whats causing this and how to resolve it? Thanks for your time!

  • #2
    Sip as a protocol being enabled or not within the system should not be the cause of your troubles. I would look at your firewall to make sure no ALG policies, QoS restriction or, some form of traffic shaping isn't responsible for your problems.
    Lance Paddock
    BTX | Business Telephone eXchange
    1(800) 289-0299

    Comment


    • #3
      I wasn't sure if SIP would have to do with anything, but since it was the only thing I changed before the issues started I figured I would mention it. As for Firewall, I checked our pfSense logs and there doesn't appear to be any interference from it. Our firewall has been online for some time with no prior issues and no settings on it were changed that I could find.



      Comment


      • #4
        To be safe I would take a fully recoverable backup of your system. Then I would do some deep digging and testing. Not many things can cause the issues you have that are not quality-related but there could be a chance of hard drive issues or possible database corruption.

        Lance Paddock
        BTX | Business Telephone eXchange
        1(800) 289-0299

        Comment


        • #5
          I had a user this morning who was experiencing the menu skip. After checking the Shoretel director diagnostics and seeing no discrepancy, I checked the switches and the firewall. Nothing unusual stuck out. They were not experiencing any network latency and network speeds were good. I had them reboot their phone and it started working again. I am not sure if it was just the normal, wait and it goes away, or if the reboot resolved it but this particular user has had this issue for a few days on and off so I will continue to monitor. In the meantime I have a few backups of the system from before this started happening so I will prep one and dig around a bit.

          Do the number of Trunks for Voicemail notification have anything to do with it? We have it set to 4 currently.

          Comment


          • #6
            does this issue only exist from phone to server or does it happen externally to the server as well?
            Lance Paddock
            BTX | Business Telephone eXchange
            1(800) 289-0299

            Comment


            • #7
              My IT subordinate and I had the issue with our voicemail this morning. I tried getting my messages from my office phone and it would not play and menu items skipped. I attempted to access voicemail from Shoretel Communicator and it would not play. The email forwarding of the message worked fine and I was able to listen to the message from email. I saw your reply and tried it externally and it played fine, but I do not know if that had anything to do with it because both our office phones started working for voicemail as well around that time, in line with the inconsistent nature of the problem.

              Comment


              • #8
                I still believe this sounds like a QOS or local priority issue between phones, server, and local switches/firewall. Your recorded audio sounds correct so I would start eliminating paths between devices and do some isolation testing with your equipment.
                Lance Paddock
                BTX | Business Telephone eXchange
                1(800) 289-0299

                Comment

                Working...
                X