Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Random users can't play voicemails via Connect client

    Since upgrading from Connect build 21.84.5535 to 21.88.3753 I've had a number of users suddenly lose the ability to playback voicemails from the Connect client through their telephone. They get an error in the client "Operation is Invalid". They can listen to messages if they switch to playback via PC speakers. None of the following steps resolves the issue:

    -Reinstall/repair of Connect client
    -Have the user sign into a different PC
    -Move the users phone to another voice switch
    -Move the user's extension to a different phone
    -Delete and recreate the users extension in Director

    What does work is restarting all Mitel related services on the voicemail server (or just rebooting the server). Then the user works fine for an undetermined period of time and then the problem can return to them after a few weeks, or the problem starts happening for other users. I've also noticed that when I have a problem user, if I delete them from director and create a brand new user with a different extension and assign to the same IP phone it works fine. As soon as I change the extension back to the original one it reverts to a broken state. Is anyone else experiencing this?

  • #2
    Sounds like something in the database is screwed up. Have you talked to your VAR about this yet?

    Comment


    • #3
      Yes I have, and they have opened a case with TAC. They wanted me to do a delete of an affected user via the dbimport tool, which I've already tried (didn't fix the problem), but now they want to do it themselves as they don't trust that I did it right...(?). If it was db related, wouldn't that persist across a reboot? Seems like a bug to me but for whatever reason TAC doesn't want to treat it that way.

      Comment


      • #4
        I have seen similar issues in builds prior to 21.88.3753. Going to 21.88.3753 has always been the fix. The only time it did not fix the issue was when the Data folder was renamed and not default (Shoreline Data). For that instance we had to uninstall, create the "ShoreLine Data"folder and reinstall
        Lance Paddock
        BTX | Business Telephone eXchange
        1(800) 289-0299

        Comment


        • #5
          Our data folder is default C:\Shoreline Data so nothing odd there. We started seeing the issue after the upgrade to 21.88.3753 - our partner ran the dbimport today against an affected user and it behaved the same for them as it did for me (didn't fix the issue). They are getting it escalated with TAC.

          Comment


          • #6
            Definitely keep us posted.
            Lance Paddock
            BTX | Business Telephone eXchange
            1(800) 289-0299

            Comment


            • #7
              Seen this problem on a customer of ours, restart Director resolved the issue for one user encountering the problem. The user has not reported the problem since. This it has to do with the TMS request and the VM Port Manager not updating, thus not placing a call to the telephone. The Connect Client logs will reflect an Event MEDIAENGINE - playViaDeskphone: Playing via desk phone. You will see: ERROR: voicemail_utility.mapErrorAndDisplayMessage: Error code = F0000060, Message: Operation is invalid.
              I believe TAC is aware of this issure on Build 21.90.9738.0, hopefully they will resolve it with the next SP2 build.

              Comment


              • #8
                Thank you tonyrolm - I see that exact error message in the client connect log when the error occurs. Still waiting to hear back from our partner.

                Comment


                • #9
                  Seeing the same thing with a 3753 customer. Thanks for the info!

                  Comment


                  • #10
                    To comment on what Lance said, this was a known defect that plagued the 9727 build. Moving off of this build immediately fixed the issue, but it appears to have been resurrected from the dead on the 3753 build. Playing visual voicemail messages fail as well on the 480/485s.

                    Comment

                    Working...
                    X