Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Any other partners locked out of the partner site?

    Tried to log into the partner site today and it has a new look and feel. All my old links of partners.shoretel.com point to the new site.

    My email/password is no longer valid and I can't even request a new password.

    Anyone else or am I just lucky?

  • #2
    Yes, I seem to be locked out now too. We got an email last week that we should be able to use our old credentials until they send us new sign up instructions for a single sign-in user name and password:

    Coming Soon: Your New Mitel Partner Portal
    Mitel Channel Comms channelcomms@mitel.com

    On Monday, June 4, we will launch Mitel MiAccess, your new single portal to Mitel partner-specific tools, knowledge, and resources. Mitel MiAccess will enable you to use the same tools, but from a single sign-on portal and with additional resources to enhance your Mitel experience.

    How to Get Started
    In the coming days, you will receive two account-related emails with instructions for creating your account:
    Email 1: login details + account creation instructions
    Email 2: your temporary password
    Upon receipt of both emails, please take a moment to validate and authenticate your account. You will continue to use your existing login credentials until Monday, June 4.

    Once you have validated your account, sign up to get a first-hand overview of MiAccess on Tuesday, June 5.

    Comment


    • #3
      I got an email "Welcome to Mitel MiAccess!" "You will receive a separate E-mail containing your user name and a link to activate your account.
      Please use the following password to access the application: ********"

      I setup the new password to match my Shoretel login. I just tried to login and it appears that they have changed to old Shoretel site to use the Mitel "single sign-on portal".

      Also I was now able to log into the Mitel User Group.

      Comment


      • #4
        Had to do a password reset, the password they gave me didn't work.

        Comment


        • #5
          Yep.
          Password reset doesn't work either.
          I also never got an email to begin with, I had no idea this was about to happen.

          Comment


          • #6
            I got the welcome email this morning, hope everyone else gets in!

            Having fun trying to find the downloads, all my links are broken.

            Comment


            • #7
              This was really done poorly, now I am getting this error:

              We can't log you in. Check for an invalid assertion in the SAML Assertion Validator (available in Single Sign-On Settings) or check the login history for failed logins.

              Comment


              • #8
                Got the same error after following instructions/ emails. We can't log you in. Check for an invalid assertion in the SAML Assertion Validator (available in Single Sign-On Settings) or check the login history for failed logins.

                Comment


                • #9
                  Also getting the SAML error here. I did receive the welcome email with the link to reset my password last week.

                  Comment


                  • #10
                    Awesome!
                    I still haven't gotten any email!

                    Comment


                    • #11
                      No access, no email, no old credentials work...

                      Comment


                      • #12
                        Same issue. Getting a single sign on error. Have a trouble ticket opened

                        Comment


                        • #13
                          I sent them an email last week explaining my situation (which is similar to all of you) and they sent me a reply that simply had a password reset link. This worked to get me back in, but I cannot find any links to download system software and other links appear to be broken. I assume this will all be fixed once they complete the change over to this new site. Cutovers are always a pain in the buttocks, but this one in particular seems nasty.

                          Comment


                          • #14
                            I got an email back from them saying that they have no record of my account nor from my company!! You have got to be kidding me!

                            Comment


                            • #15
                              Still no access... We did a connect upgrade over the weekend - thank the stars we didn't need anything...

                              Was told it would be fixed by lunchtime today (uk) but nope.. It's TSB all over again :-)

                              Comment

                              Working...
                              X