Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Outbound calls to cellphones come up as unknown

    We did have caller ID problems with our carrier which have been resolved for landlines. I was wondering if anyone has found a way to keep our outbound number and or business name when calling cellphones. Right now it just comes up as unknown. Which in a lot of cases our sales reps have their calls screened every time and have to leave a voicemail and then they will get a call back. Because lets face it, who actually answers unknown calls?

    Has anyone found a tried and true way of getting around this? At this point I would be happy if our number showed up on calls.

    Thank you,

    Seth

  • #2
    I'm assuming you are dialing out on a PRI trunk group? Make sure your trunk group is formatting and sending outbound CID in E.164 format. Depending on software level - there are some custom dial plan rules needed, and on newer versions like 14.2 and above, there should be an option in Trunk group formatting (as in check box option) to enable E.164 to be used on that thunk group.

    Comment


    • #3
      Below lays it out....bottom line is copy the ISDN profile and add " CallerIDScreeningIndicator=userpassed " to it, then change the trunk to use this new profile.....

      The Calling Party Number (CallerID) is showing up on Mobile phones as Unknown/Unknown. By default ShoreTel sends the “Screening Indicator” is 0x80 (not screened). This will cause AT&T and maybe other mobile carriers to not display the CallerID because they may assume that it’s not verified as a legit number or spoofed.


      Currently ShoreTel sends as default 0x80:

      Number IEs:
      Calling number: 6c c 21 80 32 30 35 32 36 33 35 35 30 30
      Called number: 70 c 80 31 34 31 37 39 36 32 33 30 32 32
      Redirecting num: 74 d 21 80 80 32 30 35 32 33 36 35 37 31 38


      Q.931 Screening Indicators:
      • 0x80 = Allowed, user provided, not screened
      • 0x81 = Allowed, used provided, passed network screening
      • 0x82 = Allowed, used provided, failed network screening
      • 0x83 = Allowed, user provided, network provided
      Resolution
      An entry in the ISDN Profile is needed to change the “Screening Indicator” to 0x81 or 0x83 for the CallerID to be displayed.

      Use this in the profile when the “Screening Indicator” needs to be set to 0x81:
      CallerIDScreeningIndicator=userpassed”



      Comment

      Working...
      X