Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AzBrewsky
    replied
    Below is a dhcpd.conf file in a CentOS (Linux) server we use for a different style of system. I changed it to work on your server. Just copy and paste as needed then restart the dhcpd service. Notice the option is outside the subnet configuration and it uses "text" not "string".

    authoritative;
    ddns-update-style none;
    option shoretel-server code 156 = text;

    subnet 10.1.0.0 netmask 255.255.255.0 {
    range 10.1.0.100 10.1.0.199;
    default-lease-time 43200;
    max-lease-time 43200;
    option routers 10.1.0.1;
    option subnet-mask 255.255.255.0;
    option domain-name "xxxx.local";
    option shoretel-server "ftpservers=10.1.0.100,configServers=10.1.0.10 , layer2tagging=0, country=1, language=1";
    option domain-name-servers 192.168.10.2, 8.8.8.8;
    }

    Leave a comment:


  • oz81dog
    replied
    Originally posted by Kevin View Post
    Try using this statement in your dhcpd.conf:

    # Shoretel custom option
    option shoretel-server code 156 = string;
    option shoretel-server "ftpserver=10.1.0.100, country=1, language=1, layer2tagging=1, vlanid=10";

    *** This is going to turn on VLAN tagging and set the VlanID=10 to turn off VLAN tagging change the 1 to a 0 in "layer2tagging=1" The country=1 is for the US and the language=1 is for English.

    -Kevin
    Where abouts in the dhcpd.conf does this go? When I put it up top it doesn't seem to get passed on and when i put it within the scope i get an error starting the service saying option definitions may not be scoped.

    Leave a comment:


  • regner
    replied
    Hallo, ich habe das selbe Problem.

    Wenn ich

    option code-156 code 156 = string;
    option code-156 "ftpservers=....., country=5, language=3";
    einstelle funktioniert es auch nicht. Die Telefone bekommen zwar eine IP
    aber die anderen Optionen werden nicht mitgegeben ?

    DANKE

    Leave a comment:


  • Kevin
    replied
    Try using this statement in your dhcpd.conf:

    # Shoretel custom option
    option shoretel-server code 156 = string;
    option shoretel-server "ftpserver=10.1.0.100, country=1, language=1, layer2tagging=1, vlanid=10";

    *** This is going to turn on VLAN tagging and set the VlanID=10 to turn off VLAN tagging change the 1 to a 0 in "layer2tagging=1" The country=1 is for the US and the language=1 is for English.

    -Kevin

    Leave a comment:


  • mshields
    started a topic How to configure Option 156 in Linux dhcpd

    How to configure Option 156 in Linux dhcpd

    We are putting in the Shoretel system in the next few weeks and our vendor has gave us a How-to worksheet for adding setting to DHCP. The problem is it's for Windows DHCP. We are a 100% Linux shop and use ISC's dhcpd. Does anyone have an example config for dhcpd.conf?

    How to setup Option 156
    How to setup DHCP option 156 for ShorePhone IP110/210/212k/530/560/560g telephones:
    Step 1 Open DHCP Manager on your Microsoft DHCP server.
    Right-click the DHCP server, and select Set pre-defined options.
    Click Add.
    Set Name to IP Phone Boot Server
    Set Data Type to String
    Set Code to 156 and add a description, if desired.
    Navigate to the scope options and add option 156.
    Set the value of option 156 to: ftpserver=10.1.0.100, country=n, language=n, layer2tagging=n, vlanid=10
Working...
X