Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Echo?

    Hello everyone,

    We are running Shoretel 7 and have been getting complaints from users about echo on their end. The outside caller does not hear the echo.

    All of the headsets have a pronounced echo (GNNetcom 9300 series) that was not present on the legacy analog phone system.

    But a few HANDSET users have complained as well.

    The echo seems to come and go somewhat both in HQ over PRI & copper as well as the Field offices coming over the WAN.

    Reports are showing no issue with Jitter.

    I am not really sure where to begin... Any ideas?

    Thanks in advance

  • #2
    What Codec are you using? can you use reports to isolate it to certain lines? If so, you can adjust the gain on the switch.

    Comment


    • #3
      Thanks for the reply.

      I'll have to check what CODEC is being used. Where do I find that?

      What report would I use to narrow it down?

      Comment


      • #4
        Codec is under: CALL CONTROL | OPTIONS
        Usually, I use G711 for Intra,and G729a for Inter-site
        Linear broadband can sound kinda funny at times.

        If you know what user, and an approximate time, run a User detail report with those variables. On the far right, it will list the trunk used to complete the call. Look for a pattern. If it's every trunk on a T1, then you may need to adjust the Gain on the T1 switch for each channel. Be carefull though, the range for gain is usually -6 to +6. Don't go crazy here. Start in increments of 2.

        Comment


        • #5
          Echo

          All our users that complained of ECHO were fixed by lowering the microphone gain on the headsets themselves. The microphone was set so high/sensitive that is was picking up the voices from the earpiece and retransmitting them back through the microphone.

          It may not be your problem, but it sure fixed ours... and it was easy. Since you have handsets complaining as well you may have other problems.

          It may just be "Sympathy Echo's" though as well. Once once person has it, everyone thinks they have it too.... even if they really do not.

          Comment


          • #6
            We adjusted the gains on the headsets and it did not address the issue.

            We are using G.711 for Intra-Site calls and G.729a for Inter-Site calls.

            Could the CODEC actually cause an echo? I thought it would be more call quality than echo.

            I will try to get more precise details from users (always a fun project!).

            Comment


            • #7
              I totally missed the "Headset" portion up above. The Shoretel phone has a built in amplifier, and when you attach an amplified headset, well...it sounds like crap. Is the headset they are using Amplified? If so...BINGO! You can try to turn it down, but amplifing an amplified signal is the cause. We only sell Plantronics, so I have no idea if this headset is amplified or not.

              I actually check on that during site discovery, and suggest new headsets if I run across amplified units.

              Comment


              • #8
                A couple of things that helped my install

                I had similar issues with my v7.x ShoreTel install. Here are some of things that helped. Using any wireless headsets adds a new layer of trouble shooting so DO NOT RULE OUT that the problem might be the headset. I did initially and spent a lot of time with a network sniffer and found no network problem.

                Many of the users I have are connected via Plantronics CS-50 headsets. They do have their own audio levels to adjust and they do impact the quality of the audio.

                Here is a link that helped solve a "static noise" problem with the CS-50:
                http://www.founderstelecom.com/plcsrein.html

                I am using SIP trunks and I had to use the g.711 codec ONLY because in the latest release of v7.x Release 12.6.2301.0 ShoreTel broke something that affected the negotiation of the G.729 codec between the Ingate (proxy) and the ShoreTel switch. It is causing calls to be dropped while trying to transfer them. I added more bandwidth to my remote sites to compensate rather than wait for ShoreTel to figure it out. Once the folks at Ingate told me what was happening I started changing the ShoreTel parameters until I got it working.

                One other thing might help, under "Call Control" , "Options" you might want to drop the "Maximum Inter-Site Jitter Buffer: " to a lower value. I am running 20ms and it seemed to improve the random echo a bit.

                Local echo is a reflection of the users voice coming back at them for a couple of reasons, usually too big a buffer (yes, I know it says Jitter Buffer) or over amplification (too much energy) which it seems all of the headsets available today seem to do. Before we cut over from our copper based PBX, we had the opposite problem, we had the problem of people not being able to hear us, so everyone jacked there headset volume way up. Now it is working against us, although I think it is under control!

                Chris

                Comment


                • #9
                  This is a great one!

                  I forgot you can also adjust the audio levels on the phones themselves
                  and tripped over this thread on the topic:

                  http://www.shoretelforums.com/forums...hread.php?t=39

                  Comment

                  Working...
                  X