Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • VLAN using Adtran equipment

    Does anyone here VLAN their shoretel system with Adtran equipment? We are going to be starting this project and wanted to hear from anyone who already has, especially if you use a router or switch for your DHCP server... Thanks in advance!

  • #2
    I have setup shoretel on Netvanta 1335 routers with 1234 and 1238 switches, using vlan tagging . I have also setup dhcp on both the routers and switches. Let me know how I can help.

    Comment


    • #3
      Adtran Vlan tagging

      Hi, im interested as well. Can you show us the adtran configs you are usuing?

      Comment


      • #4
        Wow this was a while ago. We are finally getting to this project, but when the phones reboot to get a VLAN IP, they just hang on waiting for an IP. The rotuers are 3448's and the switches are 1224ST POE. The phones are IP560's and IP230's

        Comment


        • #5
          Originally posted by abuthemagician View Post
          Wow this was a while ago. We are finally getting to this project, but when the phones reboot to get a VLAN IP, they just hang on waiting for an IP. The rotuers are 3448's and the switches are 1224ST POE. The phones are IP560's and IP230's
          Did you ever get this working. I'm having trouble getting vlans working on a 1638p.

          Comment


          • #6
            If your phones aren't getting IPs on the Voice VLAN make sure of a few things.
            1. If your Voice VLAN is tagged on the switch port, be sure to turn on VLAN tagging in DHCP option 156
            2. Make sure you have a DHCP server or DHCP forwarding on the Voice VLAN.
            3. Make sure you have a DHCP scope setup for the Voice VLAN.

            Comment


            • #7
              Originally posted by activitie View Post
              If your phones aren't getting IPs on the Voice VLAN make sure of a few things.
              1. If your Voice VLAN is tagged on the switch port, be sure to turn on VLAN tagging in DHCP option 156
              2. Make sure you have a DHCP server or DHCP forwarding on the Voice VLAN.
              3. Make sure you have a DHCP scope setup for the Voice VLAN.
              As of now, I'm just testing the switch vlan with a laptop trying to obtain an ip from my dhcp server which is on the same vlan. I'm really not sure where the problem is. I've created a vlan in the switch and assigned it to some ports on the switch but i'm not sure what else I need to do to make it work. I don't see any option to enable tagging.

              Comment


              • #8
                So does your laptop receive an address from the DHCP server? Are you using tagged or untagged VLAN ports on the switch?

                Comment


                • #9
                  Originally posted by activitie View Post
                  So does your laptop receive an address from the DHCP server? Are you using tagged or untagged VLAN ports on the switch?
                  No, my laptop doesn't even receive an ip address from the DHCP server. That's the problem. I'm not sure if it's tagged or untagged as I don't see that terminology in the 1638p switch. I was hoping someone with adtran experience had some tips.

                  Comment


                  • #10
                    Unfortunately, I'm not familiar with Adtran config or commands. You need to make sure the ports for the laptop and DHCP server are untagged on the VLAN (unless you're doing tagging on the devices, which is not a default). Adtran may use "trunk" or "trunked" instead of "tagged".

                    Comment


                    • #11
                      Thanks, I figured out my problem. It was a firewall issue which I'm using as the dhcp server on my new vlan. I had to set the firewall to "Send and receive un-tagged traffic". Firewall is then connected to a port on my switch which is tagged. My laptop was then connected to another tagged port which was able to receive an ipaddress from my dhcp server. I did find the trunk setting. For each port on the adtran there is a drop down menu to select a vlan or trunk.

                      Comment


                      • #12
                        Adtran commands are very similar to Cisco if you want to use CLI or you can just use the GUI. At our sites we have a normal data vlan as well as a voice vlan. The scrubbed config below has a vlan ID of 35 for voice. We do not have the shoregear switches plugged into this switch as they are on our core GB switch. When you plug the switches in, you need to change the "Native Vlan" setting on whatever port you plug them in to the 35 or voice vlan.

                        !
                        !
                        ! ADTRAN, Inc. OS version 17.07.01.00.E
                        ! Boot ROM version 15.01.B1
                        ! Platform: NetVanta 1335 PoE, part number 1700525E2
                        ! Serial number xxxxxx
                        !
                        !
                        hostname "BPFrank1335sw1.110"
                        enable password encrypted xxxxxxxxxxxxxxxxxxxxxx
                        !
                        clock timezone -5-Eastern-Time
                        !
                        ip subnet-zero
                        ip classless
                        ip routing
                        !

                        !

                        ip domain-name "xxxx.xxx.xx.xx"
                        ip name-server xx.xxx.xx.xx xxx.xxx.xxx.xx
                        !
                        !
                        no ip route-cache express
                        !
                        no auto-config
                        !
                        event-history on
                        event-history priority notice
                        no logging forwarding
                        no logging email
                        !
                        service password-encryption
                        !
                        username "xxxxxx" password encrypted "xxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
                        !
                        banner motd #
                        Only Authorized Engineers procceed! Anyone who proceeds without authorization
                        can be penalized to the full extent of the Law! #
                        !
                        !
                        no ip firewall alg msn
                        no ip firewall alg mszone
                        no ip firewall alg h323
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        no dot11ap access-point-control
                        !
                        !
                        !
                        !
                        ip dhcp-server excluded-address xxxxxxxxxx xxxxxxxxxx
                        ip dhcp-server excluded-address xxxxxxxx xxxxxxxxx
                        ip dhcp-server excluded-address xxxxxxxxxx xxxxxxxxxxx
                        ip dhcp-server excluded-address xxxxxxx xxxxxxxx
                        ip dhcp-server excluded-address xxxxxxxxxx xxxxxxxxx
                        ip dhcp-server excluded-address xxxxxxxxx xxxxxxxx
                        ip dhcp-server excluded-address xxxxxxxx xxxxxxx
                        ip dhcp-server excluded-address xxxxxxx xxxxxxx
                        ip dhcp-server excluded-address xxxxxx xxxxxxxx
                        !
                        ip dhcp-server pool "DATA"
                        network xxxxxxxxx 255.255.248.0
                        domain-name "xxxxxxxxxxxxxxx"
                        dns-server xxxxxxx xxxxxxxx xxxxxxxx
                        netbios-node-type h-node
                        default-router xxxxxxxxxx
                        lease 4
                        ntp-server xxxxxxxxxx
                        option 156 ascii "ftpservers=xxxxxxxx, country=1, language=1, layer2tagging=1, vlanid=35"
                        !
                        ip dhcp-server pool "VOICE"
                        network xxxxxxxxx 255.255.255.0
                        dns-server xxxxxxx xxxxxxxx xxxxxxx
                        netbios-node-type h-node
                        default-router xxxxxxxxxx
                        lease 7
                        ntp-server xxxxxxxxx
                        option 156 ascii "ftpservers=xxxxxxxxxxx, country=1, language=1, layer2tagging=1, vlanid=35"
                        !
                        ip dhcp-server pool "Reserved"
                        domain-name "xxxxxxxx"
                        dns-server xxxxxxxx
                        default-router xxxxxxxxx
                        lease 5
                        host xxxxxxx 255.255.248.0
                        hardware-address xxxxxxxd:a6:94 ethernet
                        ntp-server xxxxxxxxxxxxxx
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        vlan 1
                        name "Default"
                        !
                        vlan 35
                        name "Voice"
                        !
                        ip flow export destination xxxxxx
                        !
                        interface switchport 0/1
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/2
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/3
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/4
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/5
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/6
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/7
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/8
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/9
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/10
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/11
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/12
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/13
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/14
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/15
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/16
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/17
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/18
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/19
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/20
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/21
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/22
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/23
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface switchport 0/24
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        !
                        interface gigabit-switchport 0/1
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        interface gigabit-switchport 0/2
                        no shutdown
                        switchport mode trunk
                        qos trust cos
                        !
                        !
                        !
                        interface vlan 1
                        description LAN
                        ip address xxxxxxxx 255.255.248.0
                        ip flow ingress
                        ip flow egress
                        ip route-cache express
                        no shutdown
                        !
                        interface vlan 35
                        description Voice
                        ip address yyyyyyyyyy 255.255.255.0
                        ip flow ingress
                        ip flow egress
                        ip route-cache express
                        no shutdown
                        !
                        !
                        !
                        router rip
                        version 2
                        network xxxxxxxx 255.255.248.0
                        network yyyyyyyyy 255.255.255.0
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        ip route 0.0.0.0 0.0.0.0 xxxxxxx
                        !
                        no ip tftp server
                        no ip tftp server overwrite
                        ip http server
                        no ip http secure-server
                        ip http language English
                        no ip snmp agent
                        no ip ftp server
                        ip ftp server default-filesystem flash
                        no ip scp server
                        no ip sntp server
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        !
                        !
                        line con 0
                        no login
                        password encrypted xxxxxxxxxxxxxxxxx
                        speed 9600
                        !
                        line telnet 0 4
                        login
                        password encrypted xxxxxxxxxxxxxxxxx
                        no shutdown
                        line ssh 0 4
                        login local-userlist
                        no shutdown
                        !
                        sntp server xxxxxxxx version 3
                        !
                        !
                        !
                        !
                        !
                        !
                        !
                        end

                        Comment


                        • #13
                          I've been using the webUI. Now I'm trying to extend this vlan to another adtran switch. I've got 1 port connecting the two switches and I've set that to trunk on both switches. I can't seem to obtain an ip address on the vlan from the 2nd switch. Any ideas?

                          Comment


                          • #14
                            Originally posted by xpressmicro View Post
                            I've been using the webUI. Now I'm trying to extend this vlan to another adtran switch. I've got 1 port connecting the two switches and I've set that to trunk on both switches. I can't seem to obtain an ip address on the vlan from the 2nd switch. Any ideas?
                            Nevermind, got it working. I was plugged into the wrong port.

                            Comment


                            • #15
                              Originally posted by xpressmicro View Post
                              Nevermind, got it working. I was plugged into the wrong port.
                              :w00t: Been there done that ... and will do it again. lol

                              Comment

                              Working...
                              X