Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DTMF Tones Cut Off

    I want to generate long (ie. 2000ms) DTMF tones and allow the recipient to hear the entire tone.

    When I establish a internal call, from extension to extension, this works fine.

    When I establish an external call over the PRI, only the first 50ms of the DTMF tone is heard by the other side.

    What setting do I need to change so the ShoreTel system stops cutting off my DTMF tones?

  • #2
    it depends on the codec. If my memory serves, with G711 the dtmf is sent out of band over the PRI, but if you set the codec to G729, the codec is sent inband.

    Comment


    • #3
      Thanks for the reply,
      The codec is what I thought too, but I still can't get the tones to send inband over the PRI. I'll describe what I'm doing and maybe you can catch a mistake I'm making:

      Call Control>Codec Lists: I've created a codec called "Fax Codecs - ReceiverLine". Codec List Members are G729/8000, PCMU/8000

      Site>Headquarters: under the bandwidth section, I set all the call types to "Fax Codecs - ReceiverLine". (Intra-Site Calls, Inter-Site Calls, FAX and Modem Calls)

      After saving this configuration, I place a call into the ShoreTel system and discover that it is still cutting off the DTMF tones after approximately 50 ms.

      Comment


      • #4
        This problem is partially resolve.

        I created a Codec List containing G729/8000, and PCMU/8000
        I then set this list for the Intra-Site Calls

        For some reason it started working this time, but.....

        I want to use G711 not G729. G711 isn't even in my supported codec list. How do I add it properly?

        Comment


        • #5
          What build are you using? We had trouble with several of our Alarm panels when we upgraded to 9.2. Turns out it was a DTMF related issue. We finally found a resolution that involved ShoreTel writing new code. We tried several things in the process, one of which was logging into director in Support entry mode and modifying the DTMF length and volume. Refer to KB14709. We also are now using G711 (PCMU8000) for all calls also, both of these changes made a difference but without the new code neither one fixed our issue

          Comment


          • #6
            You are exactly right. The TAC has gotten back with me on this. ShoreTel has an error (feature?) where RFC2833 is used with G711(PCMU8000). After verion 10.2 build 15.41.9301 they've made it possible to turn RFC2833 off with a custom dial string.

            Configuring PCMU8000 with RFC2833 turned off allows me to send and receive inband DTMF with no interferance/regeneration from the ShoreTel system.

            Comment


            • #7
              i have some problems also with DTMF on g711 i get some distorted reverb tones comming back when i press digits i have olny noticed this on a v11 install. Can you please elaborate on how to disable RFC2833 with a dialplan.

              thank you

              Comment


              • #8
                mtlbeats,
                Did you ever receive a response or figure this out? I have a Polycom HDX8000 video conferencing system. I have an analog line connected to it using a port configured off of one of our Shoretel switches. Whenever we try to send dtmf tones to join a conference bridge, the providers system isn't picking up the tones. I can join just fine from an IP phone, cell, etc..

                Comment

                Working...
                X