Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 7 PCM Install Error

    Hi,
    So I am running Personal Call Manager on Win7 on 4 computers in this office. Just got this new computer, running into some problems.

    When I try to install Personal Call Manager, I get the following error:
    "Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom Action RemoveComplusSoftPhone script error -2147164145..."


    I found some stuff for this on Win XP but wasn't sure if that would apply.
    Very clean Win7 install. I've turned off the firewall, no antivirus on here yet. Framework up to date, it's windows 7 ultimate edition. No softphone installed (the 4 things under "Phone and Modem" are MS HID Phone TSP, NDIS Proxi TAPI SP, TAPI Kernel-Mode SP, Unimodem 5 SP). Shoretel/shoreware doesn't show up under registry or add/remove programs, so nothing to undo.

    ANY help would be greatly appreciated!

  • #2
    "COM+ was unable to talk to the Microsoft Distributed Transaction Coordinator"

    Were you running the install as administrator?

    Have you checked to ensure the "COM+ Event System" and "Distributed Transaction Coordinator" services are running?

    Comment


    • #3
      I know that I'm running as admin (tried a few different ways)
      How do I check Com+ and Distributed Action Coordinator?

      Comment


      • #4
        Under Control Panel->Administrative Tools->Services.

        Comment


        • #5
          Ive run into that issue several times, disable UAC and reinstall.....

          400Degreez.....

          Comment


          • #6
            Okay, bump, because that ^ is not an accepable solution. You can't expect us to just disable UAC for one malfunctioning/buggy installer?

            Trying to install Shoretel Call Manager (from Shoretel 9.1 Build 14.22.2904.0) on a shiny new Windows 7 x64 system, just won't work. First the client installer page (the ActiveX gimmick) just craps out, says "Download complete!" but does nothing from there. Installing it manually brings me to the message posted in OP, then it reverts and exits.

            Installed the call manager downloaded from the v9.2 support page, and it installed successfully and seems to work, however I don't have a way to test it yet. So the proper solution *seems* to be to use the v9.2 call manager even with a v9.1 server. Best solution I've found so far...

            Comment


            • #7
              Falcon4 - have you confirmed that this install has worked for you? I have a similar problem & this may well be a solution. Thanks

              Comment


              • #8
                Even though I have signed in as an Admin account, I have had to right click the installer before, and choose to "Run as Administrator". The disabling UAC is just for the install I would think...

                Comment


                • #9
                  I get the exact same error message "...A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom Action RemoveComplusSoftPhone script error -2147164145".

                  We just upgraded to 9.2 (from 8.1) on our way to version 11.x.

                  On Windows XP upgrading the Call Manager from 8.1 to 9.2, I looked up every possible fix for error 1720, and nothing worked.

                  The only thing that worked was actually installing the Call Manager client for v10.2.
                  As far as making/receiving calls and voicemail, this seems to work. Since we are upgrading to version 11.x in the next week or two, I'm hoping this will be a valid work-around.

                  Comment


                  • #10
                    What version/build of Call Manager are you guys trying to run?

                    Windows 7 isn't officially supported until version 11, and only Enterprise/Business editions.
                    Note, they also dropped support for Vista Home at some point.... It worked fine on 9.2

                    I was successfully running 9.2 build 14.45.9506 on Widows 7 Professional x64 though.

                    Comment

                    Working...
                    X