Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Does my QOS look right? Thanks

    Building configuration...

    Current configuration : 2362 bytes

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption

    hostname Central


    ip subnet-zero




    class-map match-all SHORETEL_VOIP
    match access-group 101
    match access-group 102
    match ip dscp 46


    policy-map VOIP_POLICY
    class SHORETEL_VOIP
    priority percent 75
    class class-default
    fair-queue
    random-detect




    interface FastEthernet0/0
    description - to Local_LAN
    ip address 10.1.2.1 255.255.255.0
    no ip redirects
    duplex auto
    speed auto
    service-policy output VOIP_POLICY

    interface Serial0/0
    description to Pine_Valley
    bandwidth 384
    ip address 192.168.104.1 255.255.255.0
    no ip redirects
    service-policy output VOIP_POLICY


    interface Serial0/1
    description to 6th Street
    bandwidth 384
    ip address 192.168.103.1 255.255.255.0
    no ip redirects
    service-policy output VOIP_POLICY

    interface Serial0/2
    description to Pimlico
    bandwidth 384
    ip address 192.168.106.1 255.255.255.0
    no ip redirects
    service-policy output VOIP_POLICY

    interface Serial0/3
    description to Connie_Griffith
    bandwidth 384
    ip address 192.168.108.1 255.255.255.0
    no ip redirects
    service-policy output VOIP_POLICY

    router eigrp 1
    passive-interface FastEthernet0/0
    network 10.0.0.0
    network 192.168.102.0
    network 192.168.103.0
    network 192.168.104.0
    network 192.168.106.0
    network 192.168.108.0
    no auto-summary
    no eigrp log-neighbor-changes

    ip classless
    ip route 0.0.0.0 0.0.0.0 10.1.2.250
    ip http server
    ip pim bidir-enable


    access-list 101 permit udp any any eq 2427
    access-list 101 permit udp any any eq 2727
    access-list 101 permit udp any any range 5440 5446
    access-list 101 permit udp any any eq 5004
    access-list 102 remark : ShoreTel Server VoIP Packets
    access-list 102 permit udp any gt 1024 host 192.168.10.20 gt 1024
    access-list 102 permit udp host 192.168.10.20 gt 1024 any gt 1024


    Central#

  • #2
    a couple thoughts:

    match-any instead of match-all in the class-map

    make sure that f0/0 interface negotiates to full duplex

    are you marking DiffServ (call control -> options)? if so udp 5004 isn't so important and if you're doing SIP it isn't at all

    how many concurrent phone calls per 384k circuit? three people checking their voice mail at the same time over one of those will kill the bandwidth. i'd be concerned about going with as little as 384 for a single user just based on the router's ability to queue 1500 byte data packets intermixed with 200's for voice.

    those are my thoughts. hopefully somebody else will weigh in who's sharper than me.

    Comment


    • #3
      class-all

      Matt is spot on witht the match-any

      a match-all statement will require that the traffic matches 101, 102 AND has a DSCP marking of 42... match any will accept traffic that meets just one of the lists.

      384 total is going to be REALLY tight if you have more than a couple of users......

      sure your voice traffic *may* get through, but all your other traffic is going to be left with 25% of 384k or 96k...... less than two dial-up modems.

      Comment


      • #4
        Thanks

        Thanks Guys

        Comment


        • #5
          Given the sparse amount of bandwidth, you should implement cRTP on your Cisco's to squeeze out additional bandwidth. This will compress the RTP headers.

          From a Shoretel server perspective, 9.0+ marks the RTP packets from the server with a DSCP value, so you can just match on DSCP 46 if you only care about the voice payload.

          You are likely going to have issues with PCM at the remote sites given the small bandwidth. Depending on how important that is, you might consider writing an access list to prioritize other traffic from the Shoretel server into one of the AF classes in DiffServ.

          Comment

          Working...
          X