Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reporting - Weird Issue

    I am having an issue with the account codes we implimented on Dec 16th. Sometimes they show up in the database, sometimes they dont.

    This makes me wonder if its actually requesting an account code or they are somehow bypassing it.

    I checked the shorewardcdr and achrived sql databases with this query:

    SELECT * FROM archive.call
    WHERE billingcode > '1' AND starttime BETWEEN '2009-12-15' AND '2010-01-09'

    SELECT * FROM shorewarecdr.call
    WHERE billingcode > '1' AND starttime BETWEEN '2009-12-15' AND '2010-01-09'

    They both came back 1677 rows. Great!

    Then i ran this query:

    SELECT * FROM shorewarecdr.call
    WHERE longdistance = '1' AND starttime BETWEEN '2009-12-15' AND '2010-01-09'

    SELECT * FROM archive.call
    WHERE longdistance = '1' AND starttime BETWEEN '2009-12-15' AND '2010-01-09'

    shorewarecdr came back with 2053, archive came back with 1300. Not one archive db call had a billingcode and some of the shorewarecdr results did have a billingcode.

    How can something be listed as long distance but not have a billing code even though you require it on the user group assigned to everyone? Also, why would it list it in one database but not the other.

    Maybe i am missing some information that would fill this gap or something is wrong with the server.

    Thoughts would be greatly appreciated! :P
Working...
X