Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Call Manager not connecting to phone

    Hi all,

    I have been looking for a solution to this problem and have found a few posts with similar issues and tried their solutions but as yet have not had any luck.

    We have a client computer running XP-SP3 with the ShoreTel call manager application installed.

    This has been configured with the users settings (e-mail etc) and when started comes up with the extension. I have tried the 'CTRL+F12' feature to check the connection to the server and this appears to be healthy.

    The phone is connected to its own dedicated ethernet port, as is the computer. They are not 'sharing' the same connection. We have this setup on a number of other desks and it works fine.

    On this machine we just get the red X icon on the top right corner of the call manager software saying 'Phone Disconnected - Line not in service'.

    I have tried resetting all the details on the server, resetting the phone itself. The app has been reinstalled on the client.

    Does anyone have any other suggestions? If you need any more info let me know.

    Thanks

  • #2
    I would recommend that you start by disabling all software firewalls on the machine. That's what comes first to my mind.

    Comment


    • #3
      This happened to us once on v7.0 at a site after the ShoreTel application server had a repair run on it. Call Manager and Webdialer stopped working for some, but not all users.

      The solution was to assign the user to a spare IP phone in that site and then assign them back to their primary phone. That cleared out the connection issue for us.

      Comment


      • #4
        Thank's for the replys guys, I will try the above suggestions as soon as I can get to the machine.

        Will let you all know how I go and what resolves the issue.

        Thanks again.

        Comment


        • #5
          Hi guys, I have tried a few things and nothing has yet worked.

          I have uninstalled and reinstalled the software (rebooting at every point asked).

          I have assigned the user to a different phone, reset the original phone and assigned them back.

          Firewall is disabled.

          Any other ideas? If you need any more info let me know.

          Comment


          • #6
            After reading this post I removed the TAPI config and readded it in the modem settings in control panel and it reconnected.

            http://www.shoretelforums.com/forums...ng-server.html

            Comment


            • #7
              We found that our problem with this was that our proxy was blocking this traffic. All you have to do is add either the host name or ip address of the ShoreTel server to the exceptions list in internet options:
              Internet Options > Connections > LAN Settings > Advanced > Exceptions [add the ip address or hostname to list]
              Our problem was when we added this to the list, we added it as server_hostname.domain.com instead of just the server hostname and/or ip address.

              Hopefully this helps with your problems, otherwise ignore this. Maybe it will help someone else who searches on here.

              Good Luck!

              Comment


              • #8
                I actually ran into this problem again when we were installing a new Terminal Server and we were able to see all the voicemails and call history and everything even though it said that 'Phone Disconnected - Line not in service' and when we did the 'CTRL + F12' the CSIS Status says it is healthy. The problem is not with the CSIS, it is with the TAPI connection back to the ShoreWare Director server.
                Here is how we resolved the problem:

                Check the ShoreTel Remote TAPI Service Provider:
                1. Go to the control panel and open up the 'Phone and Modem Options'
                2. Click on the 'Advanced' tab
                3. Highlight the 'ShoreTel Remote TAPI Service Provider' from the list
                4. Click the 'Configure' button to check the settings and if in the 'Provider Status' window it says anything about an error it needs to be deleted and recreated

                Remove the ShoreTel Remote TAPI Service Provider:
                1. Go to the control panel and open up the 'Phone and Modem Options'
                2. Click on the 'Advanced' tab
                3. Highlight the 'ShoreTel Remote TAPI Service Provider' from the list
                4. Click the 'Remove' button

                Add the ShoreTel Remote TAPI Service Provider:
                1. Go to the control panel and open up the 'Phone and Modem Options'
                2. Click on the 'Advanced' tab
                3. Click the 'Add' button
                4. Highlight the 'ShoreTel Remote TAPI Service Provider' from the list
                5. Check the 'Application Server' checkbox
                6. Enter <ip address of the Shoreware Director Server> in the 'Server:' field
                7. Enter <ShoreTel> in the 'Login:' feild
                8. Leave the rest blank and then click 'Apply' and 'OK'

                This was on a Windows Server 2003 R2 with Service Pack 2 set up as a Terminal Server but im sure that this would be the same fore the Windows XP. This should solve the problem that was described above.

                Best,

                Comment


                • #9
                  Kyle,
                  Thaks for info, worked perfect

                  Comment


                  • #10
                    To fix this issue on XP SP3, I went to Control Panel / Phone and modems / Advanced/ then toggled (disabled and re-enabled) the ShoreTel TAPI provider.

                    Comment


                    • #11
                      Migh not be much help but I had something similar.

                      My office is around 20 handsets.
                      SG 90BRIV
                      Originally installed at 9.1.
                      Call Manager initially installed on my desktop PC. XP Pro SP3

                      During install I conected my Call Manager to 3 or 4 handsets and it worked fine.
                      Later I installed call Manager for all other Fat Client users and found that none would log history and one laptop wouldn't even connect to handset.

                      I reinstalled my XP Pro SP3 OS on my desktop and mine stopped logging history.
                      Reinstall of Call Manager would not resolve call history issue.

                      For other reasons we then had to upgrade to 10.1.
                      Updated Call Manager for all users and it now logs history.

                      EXCEPT... The original laptop that wouldn't connect to the handset.
                      I am told that it flashed some sort of TAPI clash message but didn't see it myself.
                      Formatted the harddrive and reinstalled the XP Pro SP3 OS and all Aps on the Laptop and it now works fine.

                      This laptop was an HP NX6120 1GB RAM that was 5 years old and was still a member of an old no longer existing domain

                      Hopefully you can see something similar to your situation

                      Comment


                      • #12
                        Hi all,

                        I'm having the same problem now. I've tried all the suggestions listed here. I did not remove the 'ShoreTel Remote TAPI Service Provider' from the server because it was not showing an error. I did 'disable' it then 'enable' it to no avail.

                        Any other suggestions?

                        ...Scotty

                        Comment


                        • #13
                          First of all, I'm sorry for bumping an old topic.

                          I have a client who isn't able to view his call history and is not getting the "incoming call" window at the bottom right of his screen.
                          I had worked on a similar problem on another client's Communicator and removing and adding the TAPI service fixed the problem.

                          I tried the same steps I've done with the previous client, but I am unable to remove the TAPI service when I'm remotely logged into his system. The options to remove, add, and configure are greyed out and I'm trying to find a way to over-ride it with my admin rights so I can continue.

                          I know it's not a ShoreTel issue, but I'm wondering if anyone else who remote logged in to a client was able to bypass it.

                          [Edit]
                          I ran cmd with adminsitrative rights, used Telephon.cpl to open "Phone and Mode," and was able to remove/add/configure the TAPI Service.
                          Last edited by JNazareno; 01-03-2013, 02:06 PM. Reason: Found a solution for my problem

                          Comment


                          • #14
                            I have the same issue here user running windows 8.1 and the client shows off hook or disconnected I removed the TAPI and same issue accures with this one user.

                            Comment


                            • #15
                              I am having a simaler issue after one of my users updated to Windows 10, when I try to remove or edit TAPI service the "Phone and Modem" app locks up. Any ideas?

                              Comment

                              Working...
                              X