Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PCM Latency, actions in PCM are out of sync with the actions on the handset

    I thought I would share this with you in case you ever suffer the same.

    Symptoms.

    Client Running Windows Vista

    PCM would take a long time to respond to actions happening on the phone. For example, if a number was dialled on the phone it could be as much as 10 seconds before the call appeared on the screen in PCM.

    Changing Call Handling mode on PCM would function normally.

    Ping time to server <1ms

    I was also seeing intermittent error messages with PCM performing an illegal operation.

    Additional Symptom

    RDP session to server was slow to respond. Clicking start menu within RDP session would take several seconds to happen as did clicking on other icons and elements with applications on the server via an RDP session.

    When using the server locally there were no problems with responsiveness.

    The server showed no signs of having problems with resources.

    The RDP problem was the key to the issue.

    Remote Desktop slow problem solved Remote Desktop slow problem solved

    This article discusses a new feature of Windows Vista which tunes the TCP recieve window.

    This was causing the latency problem between the client and the server.

    The feature can be disabled by running the following in an administrative command prompt (User must be a local admin)

    netsh interface tcp set global autotuninglevel=disabled

    netsh interface tcp set global rss=disabled

    I also unticked the service on the Local Area Network Connection "QoS Packet Scheduler" for good measure.

    RDP now responds as it should.

    PCM is real time again.
    Last edited by ShoreTel_Dave; 05-26-2009, 08:12 AM.

  • #2
    Is this true just for Vista or other OS

    Comment


    • #3
      This only applies to Vista and perhaps to Windows 7.

      Comment

      Working...
      X