Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PCM 8.1 Not connecting to Phone.

    We are new to the ShoreTel Phone world (Installed 5/11/2009) and are loving it! I am having an issue with the PCM.
    We install the client PCM on a machine (XP or Vista (Latest SPs) and all seems to connect just fine. Directory services work and SOME Call History and voicemail will show up on it.
    Main Issues:
    1. The PCM says: Phone Disocnnected; Line Not In Service
    2. PCM will not dial from a Speed Dial (Internal Ext oor Outside #)
    3. As stated above, SOME services work, but not all the time.

    From another Thread, I checked the DEBUG - CSIS Status, and all is FINE, nor errors, etc.
    BUT - Telephone Status - Section for USer's Extension:
    HLine: 0x0
    Address ID: 0
    No open line device
    The rest of the Phoen Status is showing good data, from what I can tell.

    This is the same result on ANY machine we install the PCM - either from the DVD or from the Director Server, etc.

    Thanks for any help on this!

  • #2
    Pcm

    It sounds like you have a firewall/access list problem.

    it is possible that some ports are being allowed through from your pc, giving some functionality.

    I would try and disable any software firewalls on the machines, check your access lists between the pc and voicemail server, etc.

    Do you have any access lists between your pc and the voicemail server? Are you doing any NAT between the pc and server?

    Comment


    • #3
      I do have Firewalls in between. What ports/services do I need to have open? I will add them to the firewalls..

      Comment


      • #4
        Firewalls

        All ports utilized by the ShoreTel IP Telephony system Teldata.Wordpress.com | ParagonHost.com

        some are much more important and relavent than others

        Comment


        • #5
          Did not do anything different.
          This has been Duplicated on Pro Machines and Vista Ultimate SP1..

          Comment


          • #6
            firewalls

            i would temporarily remove all firewalls and see if the problem goes away. i would surely think it would.

            you can then look at denied logs and see what/if things are being denied.

            Many times have people sworn their access lists were correct, only to find out there was something missing a week later.....

            we also had an almost identical problem after upgrading to 8.1 however. The system did not force the PCM users to upgrade their PCM to the current version. Some things worked, line status did not. After upgrading to the current version the problems went away immediately. If you open the PCM and try to do an "update" is there a newer version available? Help > Update

            maybe someone gave you an older version of the PCM than the server code?
            Last edited by eazeaz; 05-19-2009, 10:53 AM.

            Comment


            • #7
              Are the users on the same local subnet as the shoreware director server?

              such as WS = 192.168.100.25 and Director = 192.168.100.50

              Also are you in a VLAN ?

              I had an issue where for some reason PCM did not like using the IP as the shoreware director ( I know strange ) ... as soon as I used the Netbios name of the machine ( in our case shoretel-server ) PCM came up. Go figure

              Let us know the top few questions...

              Cheers,

              Dave Safley
              Shoretel Pure IP Unified Communications Solutions | TalkShore.com

              Originally posted by japeeler View Post
              We are new to the ShoreTel Phone world (Installed 5/11/2009) and are loving it! I am having an issue with the PCM.
              We install the client PCM on a machine (XP or Vista (Latest SPs) and all seems to connect just fine. Directory services work and SOME Call History and voicemail will show up on it.
              Main Issues:
              1. The PCM says: Phone Disocnnected; Line Not In Service
              2. PCM will not dial from a Speed Dial (Internal Ext oor Outside #)
              3. As stated above, SOME services work, but not all the time.

              From another Thread, I checked the DEBUG - CSIS Status, and all is FINE, nor errors, etc.
              BUT - Telephone Status - Section for USer's Extension:
              HLine: 0x0
              Address ID: 0
              No open line device
              The rest of the Phoen Status is showing good data, from what I can tell.

              This is the same result on ANY machine we install the PCM - either from the DVD or from the Director Server, etc.

              Thanks for any help on this!

              Comment


              • #8
                Dave,

                We are not on the same LAN/Network as the ShoreTel Server or the one we have to utilize to use PCM with:

                Shoreware Director server/headquarters: 192.168.x.x
                Our Local DVM Server: 10.x.x.x
                A sample Client: 10.x.x.101
                We use Sonicwall NS3500 Firewalls
                I did put a rule in the firewall with ALL Services going direct to the actual Server IP address we are supposed to use.
                I do not have a CNAME/NETBIOS for the server.
                Voicemail integration and all functions work fine, but QUick Dial and The other functions of with the phone do not work?

                Comment


                • #9
                  japeeler,

                  Interesting - I know we had some issues of PCM not connecting and we added our Nebios machine name to our local dns zone and it fixed a couple of our W/S that had been using within their PCM configs just the IP address of the director - I dont know if that would change things.

                  I was the one that authored the ports that shoretel use's back a few years ago on my Teldata blog - not sure if there is an update to this list:

                  Google shoretel ports ( number one hit ) or :

                  All ports utilized by the ShoreTel IP Telephony system Teldata.Wordpress.com | ParagonHost.com

                  VM integration seems to makes sense as you are running a local DVM...

                  Keep us updated on this!

                  -DS

                  Comment


                  • #10
                    Japeeler,

                    Interesting you are having these issues - we are also using a NSA SonicWall between our 2 subnets - at the same location just to manage broadcast traffic. But we also put in a simple rule to pass all traffic.

                    We have only about 15 users and since going to 8.1 we have not nothing but trouble related to connection issues.

                    The server running your shoreward director what is the processor , we are running a Celeron box ( not that would matter ) ...

                    Not sure if the routed enviro is a common root point here but it is very strange for us.

                    Cheers,

                    Dave




                    Originally posted by japeeler View Post
                    Dave,

                    We are not on the same LAN/Network as the ShoreTel Server or the one we have to utilize to use PCM with:

                    Shoreware Director server/headquarters: 192.168.x.x
                    Our Local DVM Server: 10.x.x.x
                    A sample Client: 10.x.x.101
                    We use Sonicwall NS3500 Firewalls
                    I did put a rule in the firewall with ALL Services going direct to the actual Server IP address we are supposed to use.
                    I do not have a CNAME/NETBIOS for the server.
                    Voicemail integration and all functions work fine, but QUick Dial and The other functions of with the phone do not work?

                    Comment


                    • #11
                      We got it fixed. Just had to reboot the DVMs.. LOL Thanks!

                      Comment

                      Working...
                      X