Announcement

Collapse

Welcome to ShoreTelForums.com

Welcome to ShoreTelForums.com!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel/Mitel systems. ShoreTel/Mitel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel/Mitel, Inc. although you may find ShoreTel/Mitel employees sharing there experiences and expertise. If you would like more information on ShoreTel/Mitel systems, contact BTX at [email protected]

As always please support the advertisers that help support our site.

Thank You,
BTX
See more
See less
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot save user: Method '~' of object '~' failed

    I am running Shoretel 7 Build 12.5.9303.0.
    Recently a windows update was performed on this system and now I cannot save changes to the shoreware database.

    I have found a couple of references to this problem and followed all of the potential fixes, but so far nothing has worked.

    I have checked the IUSR_SERVERNAME passwords and permissions.
    I have performed a repair and compact of the database.

    I still get this error in the log file: 2/6/2009 10:44:25.936 <1834> ERROR: <5916:3812> CShoreSQL2::ExecuteCommand(ShoreSP_UpdateDN) - FAILED: catch(_com_error) : hr=80004005: Operation must use an updateable query..
    2/6/2009 10:44:25.936 <1835> <5916:3812> CShoreSQL2::ExecuteCommand(ShoreSP_UpdateDN) - exit. Duration:0, hr=80004005
    2/6/2009 10:44:25.936 <38> ERROR: <5916:5456> CDBConnection::ExecuteSharedCommand() - FAILED: catch(_com_error) : hr=80004005: Microsoft JET Database EngineOperation must use an updateable query..
    2/6/2009 10:44:25.936 <39> ERROR: <5916:5456> CDBDN::Update() - FAILED: catch(_com_error) : hr=80004005.
    2/6/2009 10:44:25.936 <40> ERROR: <5916:5456> CDBDN::Update() - FAILED: catch(_com_error) : hr=80004005.


    This seemed to be a permissions issue but I have run out of ideas, can anyone offer suggestions?

  • #2
    Access makes use of the temp folder. Check to ensure that the permissions are correct on this folder as well.

    Comment


    • #3
      Re-install was the ultimate fix

      I tried setting permissions for the C:\Windows\temp directory and every other place it seemed applicable and never did get rid of this error.

      My final solution was to save the current c:\Shoreware Data directory;
      uninstall the Shorewaredirector software; then place the c:\Shoreware Data directory back and re-install the software as if I was doing an upgrade.

      Everything came back perfectly.

      Comment

      Working...
      X
      😀
      🥰
      🤢
      😎
      😡
      👍
      👎