Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DiffServ / DSCP not working??

    We have a new ShoreTel 8.1 install and I am attemting to setup QoS, with not much success. The switches are Cisco 3560's. I set the DiffServ to 184 in "Call Control" and have rebooted everything since. If I then "mirror" packets from a phone/switch/t1 to another port w/ WireShark, all have the DiffServ/DSCP byte as all 0's. I also have a QoS policy setup for routing over a WAN, however, no EF packets are getting there?? Any other ShoreTel QoS tips/tricks? Any help much appreciated.


    ShoreTel Newbie

  • #2
    Update...It appears that the devices are setting EF on some packets, but not all for some reason? Packets going to the ShoreWare Windows servers gets EF, but not the packets going to the ShoreTel switches? Couldn't imagine why, but is this by design?

    Comment


    • #3
      Packets going to the switches will not be marked with a DSCP bit (unless you've setup call control signaling to be marked).

      Shoretel marks the RTP (voice) payload with the DSCP bit you specific. Voice is point to point between endpoints (meaning phone to phone). The switches are not involved in the voice payload with the exception of calls going to trunks (PRI, POTS, etc.).

      You will see RTP marked properly to the Shoretel server but the Shoretel server is not capable of marking egress traffic with a DSCP bit. You can use ACLs on your Cisco switches to do DiffServ marking on the packets from the Shoretel server.

      Comment


      • #4
        ShoreTel only tags the voice packets with the EF when you set it in the ShoreWare Director>Call Control>Options>DiffServ. No other packets get tagged except voice.

        Cisco switches will pass it if no QoS is turned on. If you turn on QoS, you need to use the 'auto qos' commands on all ports. If QoS is turned on one port, Cisco defaults and does not trust any other ports and will strip the QoS off. :-( So make sure you turn it on for all ports. After entering 'auto qos voip trust' make sure you do the 'mls qos trust dscp'.

        auto qos voip trust
        mls qos trust dscp

        If you are using Wireshark on Windows XP, Windows does not pass Diffserv to Wireshark. You have to add a entry in registry to make windows pass Diffserv.

        [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Tcpip\Parameters]
        "DisableUserTOSSetting"=dword:00000000

        You will have to reboot after adding registry.

        GoodLuck
        Steve

        Comment

        Working...
        X