Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cisco LLQ QOS

    :taz:

    So, I'm trying to eliminate some latency issues across a 2xT1 (bonded MLPPP) point to point connection. I have a Cisco 1841 router on either end. Could someone please point me in the right direction of either how to do this w/ a low latency queue or what I need to use for an access-list of a class-map? Pretty please? I've had... minimal (non-esitent?) success on my own so far.

    Thanks!

  • #2
    Qos

    http://www.baysidemedia.com/ShoreTel...ctices_wan.pdf

    we follwed the above directions with great success.

    Comment


    • #3
      Awesome. That's what I was hoping to find. I set both routers up to have the same config as below. I placed the policy-map on the Multilink interfaces on both routers and appear to be getting class hits. Both routers are configured exactly the same on both end of the ML. Can you let me know your thoughts on this config?

      !
      access-list 101 permit udp any any eq 2427
      access-list 101 permit udp any any eq 2727
      access-list 101 permit udp any any range 5440 5446
      access-list 101 permit udp any any eq 5004
      !
      !
      class-map match-any st-voip
      match ip dscp ef
      match access-group 101
      !
      !
      policy-map voip
      class st-voip
      priority percent 33
      class class-default
      !
      !
      interface Multilink1
      ip address X.X.X.X 255.255.255.254
      ip flow ingress
      ip tcp header-compression iphc-format
      no ip mroute-cache
      ppp multilink
      ppp multilink group 1
      service-policy output voip
      hold-queue 128 out
      ip rtp header-compression iphc-format
      !

      Comment


      • #4
        VOIP Policy

        we also have one more line

        access-list 101 permit udp host 192.168.10.20 (ip address of shoretel server) gt 1024 any gt 1024

        i believe that covers QOS for voicemail access/streams and workgroups, etc.

        We also made our priority percent 75 instead of 33. while your VOIP should never need that high of a percent, it doesn't hurt if it doesnt need it. On the rare occasion that you do, it will pull a higher percentage of the circuit.

        Did you enable DSCP tagging on the shoretel server? If not, match ip dscp ef wont do much... I am also not sure if a reboot is required after setting that field.


        With the config you have, you should be able to fire up several file copy transfers across the wan, make a few phone calls between sites, and notice no voice degredation.

        looks solid to me

        gary

        Comment


        • #5
          You will have to reboot after changing the TOS bit.

          Comment

          Working...
          X