Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux DHCP Server question.

    Hello,

    We are setting up a new system. We are having a couple of issues which involve us not being able to run the DHCP server off of a windows machine. Currently, we're running it off of a linux box using ISC DHCP Server V3.1.1.

    The machine is only doing DHCP for the network with the phones (which is completely separate from our data network at this time).

    I've found some searches to be useful, but they are mostly in regards to the option 156. We have mostely 230's, but we have a 115, and a couple of other phones.. so we use the 156 and 155 options. The problem that I'm having is getting the time-server and ntp-server to work.

    Reviewing the phone's config, it picks up the ip address in the SNTP Server, but it never sets the time. You may see in the config below, where I've tried using shoretel-options which works on the 155/156 settings, but I don't seem to get much from the time-server, ntp-server, and router settings.

    For reference, 10.20.50.1 is the windows shortel box, 10.20.50.15 is the linux box. Any help or guidelines on this would be greatly appreciated.

    Code:
    default-lease-time 43200;
    max-lease-time 86400;
    ddns-update-style none;
    log-facility local7;
            option routers 10.20.50.1;
            option ntp-servers 10.20.50.1;
            option time-servers 10.20.50.1;
    
            #option shoretel-server code 003 = string;
            #option shoretel-server "routers=10.20.50.1";
            #option shoretel-server code 004 = string;
            #option shoretel-server "time-servers=10.20.50.1";
            #option shoretel-server code 006 = string;
            #option shoretel-server "dns-servers=10.20.50.1";
            #option shoretel-server code 042 = string;
            #option shoretel-server "ntp-servers=10.20.50.15";
            option shoretel-server code 155 = string;
            option shoretel-server "ftpservers=10.20.50.1, country=1, language=1, layer2tagging=0, vlanid=0";
            option shoretel-server code 156 = string;
            option shoretel-server "ftpservers=10.20.50.1, country=1, language=1, layer2tagging=0, vlanid=0";
    
    subnet 10.20.50.0 netmask 255.255.255.0 {
            range 10.20.50.30 10.20.50.255;
    }

  • #2
    Couple things...

    Which NTPd are you using and how is it setup.

    Does the phone display ANY type of time?

    option ntp-servers 10.20.50.1;
    option time-servers 10.20.50.1;
    #option shoretel-server "ntp-servers=10.20.50.15";
    Am I seeing this correctly? your first uncommented option points NTP to the windows machine?
    Last edited by Eam404; 08-13-2008, 03:14 PM.

    Comment


    • #3
      Yeah, we were trying to use the windows machine for the NTP server.. the only reason is because it's the only machine that has access to the outside world. But I tried using an NTPd server on the linux box (which couldn't synchronize itself to the outside world) but it was kinda moot.

      But the problem that we were running into was that the NTP server on the windows box was running, but not accepting any connections.. apparently by default that's the way it works and you have to make a registry change to change that.. go figure.

      Anyway, we finally got it all figured out (as far as we can tell). For future reference, this is a working dhcpd.conf for anyone who doesn't want to use a dhcp server on a windows box.

      Code:
      shore-dhcp ~ # cat /etc/dhcp/dhcpd.conf
      default-lease-time 43200;
      max-lease-time 86400;
      ddns-update-style none;
      log-facility local7;
      option routers 10.20.50.1;
      option ntp-servers 10.20.50.1;
      option time-servers 10.20.50.1;
      option shoretel-server code 155 = string;
      option shoretel-server "ftpservers=10.20.50.1, country=1, language=1, layer2tagging=0, vlanid=0";
      option shoretel-server code 156 = string;
      option shoretel-server "ftpservers=10.20.50.1, country=1, language=1, layer2tagging=0, vlanid=0";
      
      subnet 10.20.50.0 netmask 255.255.255.0 {
              range 10.20.50.30 10.20.50.255;
      }

      Comment


      • #4
        Yes actually you dont have to regedit anymore for the NTP change -- you can use group policy editor and make a few clicks and BAM done. If you'd like to get ntpd working on the linux box I can help you

        Comment

        Working...
        X