Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import .wav to Workgroup Queue

    I have created a .wav file that matches the format Shoretel requests (u-law, 8-bit, 8KHz, mono) and import it to the Queue of the last step of a Workgroup. All of the other steps have the checkbox checked to skip.
    The .wav file does not play when I get to the Queue.
    If I record a test message through the phone it plays with no problem.

    I am using Version 8 Build 13.9.3506.0

    Is there anything else that I need to do to make this play?

    Also, on page 258 of the Admin Guide in a section about Call Queuing it mentions that there's a feature to allow the callers to hear the main site's on-hold music while waiting. I don't see where to configure this to happen.

  • #2
    Originally posted by ABidlen View Post
    I have created a .wav file that matches the format Shoretel requests (u-law, 8-bit, 8KHz, mono) and import it to the Queue of the last step of a Workgroup. All of the other steps have the checkbox checked to skip.
    The .wav file does not play when I get to the Queue.
    If I record a test message through the phone it plays with no problem.

    I am using Version 8 Build 13.9.3506.0

    Is there anything else that I need to do to make this play?

    Also, on page 258 of the Admin Guide in a section about Call Queuing it mentions that there's a feature to allow the callers to hear the main site's on-hold music while waiting. I don't see where to configure this to happen.
    Can you create a test AA and import that same wav file and play it?

    If not then it is the wav file common issue. How are you creating it?

    Comment


    • #3
      I opened the .wav file in Sound Recorder on the server and saved it again w/ the proper settings and this time it worked properly. Previously I had used other software to do the conversion.

      So I guess lesson learned is that just because I didn't get an error message when importing the file (which I still believe has the correct settings) doesn't mean that the file is OK.

      Thanks for your thoughts Jlorenz.

      Comment


      • #4
        Originally posted by ABidlen View Post
        I opened the .wav file in Sound Recorder on the server and saved it again w/ the proper settings and this time it worked properly. Previously I had used other software to do the conversion.

        So I guess lesson learned is that just because I didn't get an error message when importing the file (which I still believe has the correct settings) doesn't mean that the file is OK.

        Thanks for your thoughts Jlorenz.
        , No worries, I was going to suggest sound recorder, sorry should had done that first ops:

        Comment


        • #5
          what recorder did you use?

          Comment


          • #6
            I posted a way to convert the files using a batch script in thread about ringtones. It will also work for workgroup queue waves. :balloon:

            Comment


            • #7
              After much research, I discovered that the issue that is occurring is due to ShoreTel Director and how it reads .wav files. Even though a .wav file might be recorded/saved in a certain format, it does not necessarily mean the data inside that file is in the same order. Apparently, not all .wav files are created equally. I used both GoldWave Audio Editor(v5.67), and Audacity 2.0.0 (Unicode), and both can create the wave file in the required format. (Note: I personally think that GoldWave Audio Editor(v5.67), is a much easier product to use). There are MANY posts out there regarding issues in importing these files. The ShoreTel requirements for the .wav files are fairly easy to locate. (CCITT μ-law, 8KHz, 8 bit, mono). However, the file can’t be used. Every article I read kept referencing “Sound Recorder”. This is a little program that has come with Microsoft Windows since Windows XP. However, Windows 7 does not have the same program with it. It has been pared down and no longer has the same options it did. You can no longer specify file type in it. I realized that the ShoreWare Director was designed to accept the .wav file format ONLY as it is saved by this legacy program.

              Solution: I took the .wav output from GoldWave, opened Windows XP Mode from my windows 7 laptop, opened the file with Sound Recorder, and then just hit save. It reorganizes the file somehow into a format that can be used by the ShoreTel Director. I then imported it and it worked flawlessly.

              Comment

              Working...
              X