Welcome to

Welcome to!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel/Mitel systems. ShoreTel/Mitel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel/Mitel, Inc. although you may find ShoreTel/Mitel employees sharing there experiences and expertise. If you would like more information on ShoreTel/Mitel systems, contact BTX at [email protected]

As always please support the advertisers that help support our site.

Thank You,
See more
See less
  • Filter
  • Time
  • Show
Clear All
new posts

  • Win2003 Term Server/ Call Manager / TAPI

    I'm having issues with PCM and Workgroup CM working in our terminal server environment.

    The Call Manager can control the CHM, Agent Login, and the Handfree mode. It can also look up names and numbers, but it wont let you dial out or hangup.

    The Queue Monitor will open, but isn't getting any stat's, except that it list the workgroup queue the user is in. In the bottem right, there's a computer icon with a redcircle/whiteX that says "Your TAPI connection is unhealthy or your extension is not being serviced". The extension works fine, so I have a feeling it's TAPI related.

    Does anyone have any idea's?

  • #2
    I think what I need is hidden in Appendix F of the manual...
    Last edited by JasonC; 07-23-2008, 11:01 AM.


    • #3
      Followed Appendix f, still no working TAPI. One thing I noticed, in the instructinos for..
      TSPinstall -i StServer <servername> , it has about 5 commands in the dos screen, mine had about 35....

      C:\Program Files\Shoreline Communications\ShoreWare Client>tspinstall -i StServer pac-vmail
      CTapiReg::CTapiReg 0x0012FE78 eType=1
      CTapiReg: AddProviderWithID NULL 0
      CTapiReg: Read Provider ID Value: <-- (-1)
      CTapiReg: AddProviderWithID ReadProvider Err=0x80070002
      CTapiReg: AddProviderWithID bAddProvider
      CTapiReg: _AddProvider sProviderFileName=RpcTspX.TSP
      CTapiReg: lineAddProvider (RpcTspX.TSP): <-- 8, lStatus=0x00000000
      CTapiReg: Read Tapi Providers from Registry
      CTapiReg: ReadRegistry NumProviders=7
      CTapiReg: ReadRegistry NextProviderID=9
      CTapiReg: AddProviderWithID Loading Profile eType=1
      CTspProfile: CTspProfile dwProviderID=8
      CTspProfile::LoadAppServerProfile dwProviderID=8
      CTspProfile::LoadAppServerProfile RegOpenKeyRemoteTSP hr=0x00000000
      CTspProfile::LoadAppServerProfile RegOpenKey hr=0x00000000
      CTspProfile::LoadAppServerProfile ShoreTel localhost 0
      CTapiReg::CTapiReg 0x0012FCB0 eType=1
      CTapiReg: Read Provider ID Value: <-- (2088927856)
      CTspProfile::LoadAppServerProfile ReadProviderID hr=0x80070002
      CTapiReg::~CTapiReg 0x0012FCB0
      CTapiReg: ReadAppServerProfile hr=0x80070002
      CTapiReg: AddProviderWithID ReadAppServerProfile hr=0x80070002
      CTapiReg: AddProviderWithID WriteProvideID hr=0x80070002
      CTapiReg: Write Provider ID Value: 8 hr=0x00000000 Open Key
      CTapiReg: Write Provider ID Value: 8 hr=0x00000000 Write Key
      CTapiReg: WriteAppServerProfile: 8
      CTspProfile: CTspProfile dwProviderID=8
      CTspProfile::SaveProfile 0, pac-vmail, ShoreTel
      CTapiReg: WriteAppServerProfile hr=0x00000000
      CTapiReg::~CTapiReg 0x0012FE78


      • #4
        Are you installing as Local Administrator?
        or are you installing as a user with Admin rights or Domain Admin?

        Also are you installing in Install mode?

        You have to be logged into the Server as LOCAL ADMIN, not a domain, not a user with Domain privileges


        • #5
          While, I was doing it as domain admin, but I tried with the local admin, and got the same thing.

          I'm not familiar with Install mode, so I'm guessing that's a Citrix thing.

          Would restarting the TAPI service on the director help or mess anything up? PCM works on all the PC's, not none of the Windows2003 terminal servers.


          • #6
            Provider not currently loaded by TAPI.

            This indicates that no TAPI applications are running.


            • #7
              Even if it looks like the modem settings look wrong, log somebody in and try it. IT will probably work.

              Also, INSTALL mode in TS:

              Open DOS Command box

              type: Change user /install

              When done,

              type: Change user /execute



              • #8
                Also one other Point Charles from Charles post, do not try and launch PCM from the Server itself. DO it form the User PC or Thin Client.