Announcement

Collapse
No announcement yet.
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Selectivly block caller ID: *67

    We have a PRI T1, each user is set to display their DID. But sometimes someone wants to block their ID on an outbound call.
    On my cell or home, I can dial *67 then the number and it will be blocked. How do I accomplish this in a Shoretel system?

    It does not work with 9-*67-###-#### or *67-9-###-####

    I know I can change it in the Director but I certainly do not want to go through that task every time someone wants to block the next call.

    Any help is appreciated.

    ds

  • #2
    Just tried this from PCM. I typed 9*67+1XXXYYYZZZZ, and it worked fine. All the other combinations I could think of to try resulted in calling wrong numbers (area code 967, or area code 675), getting an intercept tone, or the BAA.

    It looks like the difference is dialing 9*67, then a full canonical number.

    Sorry I can't try this from the TUI, as I'm out of the office. I tested tonight on shoretel 8, but I'm pretty sure I did this when using shoretel 7.5.

    If this still doesn't work for you, you can test using the trunk test tool. I'm able to dial *67YYYZZZZ using the test tool, and the call goes through without callerID. If you can't get it to work using the test tool dialing either *67YYYZZZZ or *671XXXYYYZZZZ, then it would probably be advisable to ask the telco if they are disallowing *67, or if it is a service they charge extra for.

    Comment


    • #3
      When dialing *67YYYZZZZ using VBTrunkTest I am able to place a blocked/restricted call.

      Telco says their PRI's do not allow the code being dialed but if I can get my equipment to dial it, it will accept it.

      OK, so I proved ShoreTel can dial the code, how can I now do this from an endpoint?

      If I Dial *679yyyxxxx or *67yyyxxxx I get "That extension is not valid"


      My apologies if this is all basic stuff, but this is all new to me.

      Comment


      • #4
        Dial 9

        Dial 9 and then the string. We do it all the time to call some of of miscreate customers.

        Comment


        • #5
          I'm able to do it multiple ways from the phone.

          (Without going off hook) dial 9*675551212 - works
          (Without going off hook) dial 9*6716615551212 - works

          Pick up the handset and dial 9*675551212 - works
          Pick up the handset and dial 9*676615551212 - -works



          It shouldn't matter, but I'm using an IP560g.
          Last edited by aclements; 05-29-2008, 04:39 PM. Reason: addition

          Comment


          • #6
            I know this is an old thread but dialing *67 does not work for me. When I dial 9*6718473082222 from PCM the system returns 9 + 1(671)8473082 in call history. If I try dialing from a phone call history shows Caller ID Unknown under the Name field with no number shown in the Number field. I've added *67 in the Permissions field on the station class of service as suggested in ShoreTel KB11402 but still no go. :confused1:

            ShoreTel 7.5 build 12.15.8700.0

            Comment


            • #7
              Notice the + in the above number. Did you try exactly as suggested? 9*67+18473082222

              Comment


              • #8
                Originally posted by Palitto Consulting View Post
                Notice the + in the above number. Did you try exactly as suggested? 9*67+18473082222
                Yes - PCM reports Cannot Complete Call (Intercept Tone)

                Comment


                • #9
                  Oldphoneguy, is that a local or long distance number?

                  It could be...
                  1) This trick doesn't work with long distance numbers
                  2) The area code and prefix table isn't completely accurate.

                  Comment


                  • #10
                    1.) Fails the same with both local and LD calls.

                    2.) Not sure which area code and prefix table you are referring to.

                    FYI - All numbers dialed in our area are 1 + ten digit. (Local & LD)

                    Comment


                    • #11
                      Do you have multiple sites? If so make sure 'user parent as proxy' is checked.

                      Comment


                      • #12
                        Found the trouble. I was setting the "scope" and the "permissions" under Telephone Feature Permissions instead of Call Permissions. Doh...

                        Comment


                        • #13
                          Sorry to revive an old thread... we are trying to use *67 on our AT&T PRI trunks but it does not work - we are on Shoretel 10.2. AT&T said that *67/*82 isn't supported any longer on PRIs (they AT&T rep mentioned that this feature did work prior to 2008...?) We are in Northern California... I am sure I used to use this feature on PRI trunks in the past!

                          Has anyone run into this and if so, were you able to figure out a way to selectively block caller ID outbound?

                          Comment


                          • #14
                            We really need this feature added. Have tried all suggestions listed above for *67 and 9 and ph# in all combinations, but the call is unable to complete.

                            Comment

                            Working...
                            X