Announcement

Collapse

Welcome to ShoreTelForums.com

Welcome to ShoreTelForums.com!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel systems. ShoreTel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel, Inc. although you may find ShoreTel employees sharing there experiences and expertise. If you would like more information on ShoreTel systems, contact BTX at info@btxchange.com

Thank You
BTX
See more
See less
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ShoreTel Connect Communicator Cert issue

    Hi Forums,

    I am really spinning my tires with this one.

    Last June, our cert for the SA100 conference bridge expired and we got a new cert through network solutions and put it on the SA100. No issues. Then in November we upgraded from 14.1 to Connect 21.82.9645.0. Finally around December January time frame we put a Wild Card cert on the Shoretel appliances to secure our connection between communicator and ShoreTel server. Up till last week Thursday everything was working just.

    Now for the issue that is occurring. ONE USER ONE! is getting this: Your Client is Sending Encrypted data. Your connection to the following Servers is not secure: Authentication (see attached) I would like to reiterate that no other user is getting this.

    Now for what I have done thus far:

    Computer: Domain Joined Windows 7 Pro computer. ShoreTel Director is on Windows Server 2012R2 box (virtual)

    - found the following on this form https://www.shoretelforums.com/forum...connect-onsite
    - On the Voice Server I verified the cert on IIS is not expired (for security reasons I will not be putting that up as screen shot)
    - Found the following MiTel articular https://oneview.mitel.com/s/article/...ty-certificate however we do not have an Edge Gateway
    - Collected Connect Client Commuicator logs
    - From logs we found that the user did not have "Use Windows Credentials" checked on the Connect Client I then checked that which then edited how her username appeared the Domain and the server name. However the cert error still occurred
    - Thinking it may be DNS related from a product that we just introduced into our environment Cisco Umbrella I installed the following windows hotfix on users computer MS Hotfix 250155. Computer was rebooted but no change
    - Next I logged in with my profile on users computer and signed into the Connect Client, and I did not get the error. Both Client and Authentication to servers was encrypted.
    - Next I had the user log back into her profile, and I logged her out of connect client, and then I logged in as me. From there I get Connect Client is sending encrypted data but connection to Authentication server is not secure.
    - So this leads me to believe its not a shoreTel issue but more of an AD related issue, I check the the users Account in AD and the computer in question and find that they are different OUs. so I get them under the same same Site (user is under "users" computer is under PC under the same site OU) rebooted computer but the issue still occurs.
    Attached Files
    Last edited by bhagen61; 04-11-2018, 07:16 AM.

  • #2
    Have you tried deleting the user in ShoreTel?

    Works for us on a myriad of issues

    Comment


    • #3
      That might be the simplest Idea that I have not tried. I will try that and update with results.

      Comment


      • #4
        Sorry for the long wait. I have deleted the users account and re-created it. I am now waiting on confirmation.

        Comment


        • #5
          MikeyB123, the issue still occurs after deleting and rebuilding the ShoreTel account.

          Comment


          • #6
            Try deleting the %localappdata%\ShoreTel folder for the affected users.

            What makes these two users unique?

            Comment


            • #7
              dnhansen,

              Thank you I will try that.

              I am not 100% sure why its only affecting these users. The users in question are all basic users none of them have elevated permissions, users that are in the same OUs as them are working without an issue, the thing I may be overlooking for one of them what if they had something related to the cert stored in the credential manager vault

              Comment


              • #8
                Deleting the shoretel folder at %localappdata%\ resolved the issue!

                Comment

                Working...
                X