Announcement

Collapse

Welcome to ShoreTelForums.com

Welcome to ShoreTelForums.com!

This site was created as a place to share stories, tips, and troubleshooting help with ShoreTel/Mitel systems. ShoreTel/Mitel is obviously the MOST exciting VoiP platform on the market right now, and we realized there was no centralized place to discuss this platform, but now there is. Please feel free to join and share your experiences.

Please Note: This site IS NOT owned, funded, or managed by ShoreTel/Mitel, Inc. although you may find ShoreTel/Mitel employees sharing there experiences and expertise. If you would like more information on ShoreTel/Mitel systems, contact BTX at [email protected]

As always please support the advertisers that help support our site.

Thank You,
BTX
See more
See less
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SoftPhone Not Working

    So, the SoftPhone looks cool, but I have yet to make it work completely.

    The current problem is that when I enable it and make or receive a call, I can neither hear the person, nor talk to the person on the other side. I am certainly connected with the phone I am calling (my cell phone). It seems to be a problem with ST Call Manager.

    Yes, my speakers and mic are connected and are working properly, just not with SoftPhone.

  • #2
    Did you disable any software firewalls, including the built-in Window firewall? Are you on the same network as the ShoreTel switch?

    Comment


    • #3
      is the computer IP address in the ip address range? we have had this happen where you will "see" the softphone but it will not work

      Comment


      • #4
        I am having the same issue... Soft Phone only works one way.

        I just converted to SIP phones.
        Now my soft phone does not work.
        It only hears one side of the conversation.

        The soft phone user can change their settings in call manager,
        so I think that means they are connecting.

        When a call is initiated, only one side can hear.
        The soft phone side can not hear the other person.

        The soft phone user is connecting to the shoretel system via vpn.
        Their ip address is a 192.168.2.x address (from their home router)
        Our shoretel system is 10.1.1.x
        gateway is 10.1.1.x

        From reading the above posts, are you saying the soft phone computer needs to be a 10.1.1.x address? We tried that, and the soft phone did not work at all.

        Is there something in the VPN that needs to be changed so that the soft phone knows how to get to the shoretel server?

        Comment


        • #5
          What type of VPN? If it's a proxy-based VPN like some SSL VPN products, it may not work. We experienced a similar issue and once we moved to a standard IPSEC client, everything worked.

          A few other things come to mind:
          Are your VPN policies allowing the subnet of your Shoretel system?
          Can you ping the Shoretel server and switches?
          Do you have the IP range of the VPN client in your IP Phone Address Map?

          Comment


          • #6
            It is IPSEC

            Where do I allow the VPN policy to allow the subnet of the Shoretel system?
            I am using a VPN Tunnel with Netgear SRXN3205

            Where do you want me to try to ping the switch from?
            I am almost sure i could as the soft phone worked fine before switching to SIP
            and we tried it back off of SIP and it works fine.

            Where do I put the IP range of the VPN client?
            Where is the Phone address map?

            I am new to this, I do not know these terms.

            Thanks

            Comment


            • #7
              I am not familiar with that Netgear but standard IPSEC implementations require that you define which subnets are allowed. There should be somewhere in the tunnel definition configuration that may show something like "remote network". You may have to define several tunnels if you have more than one logical network (eg: a subnet for phones and a subnet for PCs).

              You should try to ping the switch from the remote side running the Call Manager softphone. The idea is to test whether you're getting traffic to go both ways across the tunnel.

              We're on build 9.2 so I don't know if your build will look the same but...

              In Shoreware director, look under "IP Phones" > "IP Phone Address Map". Define your IPs there.

              It's brave for you to try to tackle this without basic knowledge of how VPNs operate or Shoretel admin experience. I'll do the best I can trying to walk you through this over a forum!

              Maybe someone who has more exposure to the Netgear device you have can chime in.

              Comment


              • #8
                there should be tons of info on setting up a netgear vpn, you should consider routing as well. Make sure the IP pool is routable on your network.

                Keyoe

                Comment


                • #9
                  The fact that it works when you remove the SIP configuration from the ShoreTel PBX means that routing, and VPN tunnels, and firewalls should all be fine. I don't see you mentioning the Build number of your system, that may help (available from the Shoreware Director login screen at the bottom in the small print).

                  Are you following a specific guide / instructions / best practices document to enable your SIP configuration by chance? (for instance, the IP-8000 manual lists a specific set of commands).

                  Trevor C
                  Optinet Systems

                  Comment


                  • #10
                    I am on version 10.1 software.
                    The ip address map say headquarters low ip 10.1.1.11 high ip 10.1.1.200 teleworkers no
                    That is it.

                    The softphone user can see the calls coming in, just can't answer them or speak to them.
                    I am not following a guide, as I do not have one.

                    Our support provider just charged us over $400 to figure this out while we also have a contract with them that we paid over $1,500 per year for, so that is why I am trying to figure this out without them. Not sure what our money was paying for.

                    Comment


                    • #11
                      Originally posted by SIPIT View Post
                      I just converted to SIP phones.
                      Now my soft phone does not work.
                      Could that be the problem there? If the soft phone worked before, maybe you were only using UDP port 5004 for RTP? Now that you are using SIP, that box has to be unchecked, meaning that the port is now randomized...

                      Just a thought.

                      Comment


                      • #12
                        Originally posted by Bobby_Digital View Post
                        Could that be the problem there? If the soft phone worked before, maybe you were only using UDP port 5004 for RTP? Now that you are using SIP, that box has to be unchecked, meaning that the port is now randomized...

                        Just a thought.
                        PORT 5004 for RTP was unchecked.

                        Comment


                        • #13
                          I fixed a problem with one way audio recently. There was a mis-configured default gateway set up.
                          The default gateway that was configured worked for pinging and so on, but replies were coming back from another router. So the ping would go out one router, the reply back via a different one on the same subnet.
                          Changed the default gateway to the one that the replies were coming back through and everything started working again.

                          Comment


                          • #14
                            Originally posted by ShoreTel_Dave View Post
                            I fixed a problem with one way audio recently. There was a mis-configured default gateway set up.
                            The default gateway that was configured worked for pinging and so on, but replies were coming back from another router. So the ping would go out one router, the reply back via a different one on the same subnet.
                            Changed the default gateway to the one that the replies were coming back through and everything started working again.
                            Where are you speaking of making these changes?
                            On the router the end user is getting on, or at the home office?

                            This sounds like it is the solution, I just don't know where to make the change.
                            If it is on the end users system, wouldn't the default gateway be their connection to the internet?

                            Comment


                            • #15
                              Originally posted by SIPIT View Post
                              Where are you speaking of making these changes?
                              On the router the end user is getting on, or at the home office?

                              This sounds like it is the solution, I just don't know where to make the change.
                              If it is on the end users system, wouldn't the default gateway be their connection to the internet?
                              These would be changes to the end points, not the routers themselves.
                              In my instance the voice had its own vlan and there were two possible routes to reach that vlan.

                              You need to check the gateway on both the PC that is hosting the softphone and the one on the ShoreGear Switch(s)

                              Comment

                              Working...
                              X